Selecting volume tool or stop playing makes audacity hang

Audacity 2.3.3 from the fedora 31 distribution often hangs in at least two situations.

After having opened and worked on a project, it often hangs when it’s playing and I stop it by hitting the space bar. This has been a problem for years, occuring more or less frequently. Recently it also often hangs when I select the volume editing tool. The cursor doesn’t change shape and still can be moved around, but the program is unresponsive to any form of interaction except quitting. Once I even had to turn off the computer.

I suspect these problems are a bit more likely on larger projects. Would it be helpful in any way if I post some of the error messages I get when starting audacity from command line?

This is a known problem. It occurs when running Audacity with PulseAudio. I generally work around this bug by selecting appropriate “hw” options in the Device Toobar ( rather than using “default” or “Pulse”.
If you know any really good C++ developers that could help to fix this, please direct them to the Audacity developer’s mailing list (

I assume that you mean the “Envelope Tool” (
If you can give precise steps to reproduce this issue, that would be helpful.

I don’t get any sound output at all if I choose anything but default or pulse. Or maybe I don’t get how to use alsamixer.
As for developers, maybe it’s time for a friendly reminder at the music-dsp mailing list again? It’s not very active these days though.

And yes, I meant the envelope tool. Here’s a simple way that works (or rather doesn’t) for me:
Open a new project. Add one mono track. Make a second of silence or whatever in the track. Split-delete a segment of audio (ctrl-alt-K). Now, before clicking in the track or doing anything else change to the envelope tool (I use the function key F2). Voilà, it hangs.

The system default device is usually listed as:
some-device-name (hw:0,0)

Note that when using a “hw” device, only one application can access the device at a time, so it is essential that no other audio apps are using the device. Setting this up for the first time, it is easiest to log out of the computer and back in again so that you have a clean start.

I can’t reproduce the problem.
The problem may be specific to fedora, so if you’ve not done so already, I’d suggest that you report this bug to them.

For now, in Fedora 31 it not works. This was a good workaround up to F30, but now it fully broken. When I’m selecting device “hw” option there no any audio output work with always showing a Error about device busy.
So we need a new solution to get Audacity work again without hanging on every few minutes with playing and I stop it by hitting the space bar.

Maybe it’s possible to check and fix ALSA-Pulse configuration to get “hw” option work again with Audacity. But I’m not experienced with this to research. Please help me if it’s possible.


With the current version of Audacity, the workaround is probably no longer necessary.
On Ubuntu, I’ve not experienced the freeze problem when using PulseAudio for some time, so now I just use Pulse.

What exactly current version? I have installed audacity-freeworld.x86_64 version 2.3.3-1.fc31 from @rpmfusion-free-updates repository on my Fedora 31.
And as I know, there are no newer versions for Fedora now. Am I wrong???

The current version of Audacity is 2.4.2.
If it’s not yet available, it should be in due course, or you could build it from the source code.