Selecting recording device via USB [SOLVED]

Hi guys!

I received Audacity with my turntable Akai ATT05U. Same as NIKKEI NTT05U. On my previous OPS (Vista) I had no troubles recording via the USB cable and port on my PC.

Ever since I upgraded from Vista I can’t record via USB. I think it has something to do with the fact that when I select the recording device, I can only select ‘Microphone USB’. See images. I have a feeling it should be another device than ‘Microphone’. I tried deleting the Microphone USB Audio CODEC. But when I hook up the turntable via USB: there it is again…
Anyone any suggestions?

OPS Windows 10
Version Audacity 2.1.2

Hope to hear from you guys.

Please describe the exact symptoms of that. Do you record a flat line? Or the blue waves are not tall enough? Or too tall (you record distortion)? Or you see error opening sound device? Or…?

Then the Microphone USB Audio CODEC is the correct name. Later Windows calls USB devices that use standard Microsoft USB Audio Class drivers as “microphones”. It isn’t the problem, but to help you with the problem we need to know the symptoms.

You may be able to solve it yourself by reading these FAQs:


Thank you for the explanation on the USB naming Gale.

Regarding the recording, I do get blue waves. But left and right are identical/mono. Although the settings are set to 2 channels/stereo. As seen in the first image. Also the sound is too fast. And yes it is distorted. However, the waves are definitely not too tall/‘loud’.

You’ve got some strange problems… Check for any [u]Windows “Enhancements”[/u] and make sure they are turned-off. Audacity is going to “capture” whatever digital audio data it’s getting from the drivers. Audacity isn’t going to mess-up your recording, but sometimes Windows can.

But left and right are identical/mono.

Left & right are usually similar so you can’t tell by looking. Make sure to listen, and make sure the record isn’t mono. :wink: The Vocal Remover effect in the “Simple” mode will subtract right from left and if the left & right channels are digitally-identical you’ll get dead-silence. The same experiment with a mono record will leave some sound and the clicks & pops will remain at full-volume since they are different in each channel.

Also the sound is too fast. And yes it is distorted.

Does the turntable have a speed adjustment? Have you connected the analog outputs to make sure everything is OK on the “analog side”?

You can also try switching your Audacity preferences between 44.1kHz and 48kHz. Usually the drivers keep everything straight, but a sample-rate error will result in a speed error.

That is probably fixable. By the system clock, right-click over the Speaker icon, choose Recording Devices then right-click over USB Audio Codec > “Properties”.

On the “Advanced” tab, in the “Default Format” section, make sure the dropdown menu is set to a “2 channel” choice.

If you are still getting a too fast recording, try “2 channel 16-bit 44100 Hz” and set Audacity project rate (bottom left) to 44100 Hz.

You can try both Default Format and Audacity Project Rate at 48000 Hz too, and you can try enabling / disabling the two “Exclusive Mode” boxes underneath where you change Default Format.


I am a newby to Audacity 2.1.2 and the Group Forum. I use an old style turntable for converting vinyl to wav files so a USB connection first requires connection to a preamp then my usb interface is a decent little Focusrite Scarlett. I think your PC/Audacity should “recognize” your turntable USB input and allow you to select it. If my USB interface is plugged into my PC and then Audacity recognizes it as a input/output option so the dropdown menu list of I/O options includes the Focusrite USB unit. Hope my 2 cents make sense. Audacity also recognizes that my A to D output is 16bit .wav format.

Hi guys,

I want to thank everyone for their input. The problem is resolved. But not in a way as I suspected.
A few remarks:

  • Yes , what I was able to record was stereo. I have enough experience in recording to visually see the waves were mono :wink: Listening to the recording confirmed that.
  • The connections were no different than on my previous PC.
  • The turntable has a preamp build in.
  • Gale’s last suggestion resulted in a horrible distortion. Which had little similarities to the sound of actual music :astonished:

Now, what was the solution? Out of frustration I tried the other USB connector in the front: error! Then the one on the back of the PC. Bingo! Recording is in stereo and clear. Also the description of the hardware is different. When connected to the front it says Microphone USB Audio CODEC. When connected to the back it says Microphone 2 USB Audio CODEC.

So again, thanks! And happy recordings everyone :slight_smile:


Thanks for letting us know. I will mark this topic as [SOLVED] and lock it.