scrolling while playing?

I have several machines, with several versions of audacity (I just hate having to re-do all my customizations every time I upgrade), but this is in regard to a windows 10 system running audacity 2.2.0

  1. When I play a track, the little bar indicating where in the track the sound is rolls right off the right edge and the screen stays static.
    Previous versions used to scroll with the bar - how can i turn this back on?

  2. A second question, not as important - when i hit mute or solo on a selected track, all the other buttons on the other tracks go the other way.
    That’s super annoying - how can I make it go back to just affecting the track I’m clicking on?

Sorry to ask two at once, but the second one seemed a bit silly for an inquiry of its own.
Thanks for any help!!

Turn Pin playback head on or off …

There are two options for solo buttons in Audacity preferences

Whatever yours is set on now, change it to the other option.

Thank you so much!!

The pin is not on, but it still isn’t scrolling.
In other words, I see the green arrow, not the pin, but the screen remains static.

OK, I see what you mean - so the “pin” makes it scroll smoothly, not jerkily (screen by screen) like it used to?
While the green arrow makes it not move at all, and the line merrily plays off the right edge of the screen?

If you don’t want that to happen, tick the box I’ve colored yellow …
ensure box I've colored yellow is ticked.png