Scrollbar disappeared

Updated to Audacity 3.1 and lost all scroll bars in the main window.
Tried AppImage pack as well as building from sourse; the same result!
When I return to 3.0.2, everything is ok.
Tried “Portable Settings” (to start app from the scratch) and no luck.
I’m on Ubuntu bionic.

Is that 3.1.0, 3.1.1, 3.1.2 or 3.1.3?

Which Desktop environment?

3.1.0 then 3.1.2, no difference

unity 7.5.0

I can confirm that. I’ll log it as a bug.

It seems was caused by adding the clip handles; possibly it’s the point to start from.

That’s weird because on 20.04 (Focal) I don’t see the problem, but on 21.10 (Impish) I do see the problem.

What do you get if you run this in a Terminal window:

lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 18.04.6 LTS
Release:        18.04
Codename:       bionic

also it worths to mention, that I did some tweaks in desktop theme; as well as in GTK2/3.
don’t know, actually, that iss Audacity using frow these ones…

I experience this as well. There is a workaround.

Steps to reproduce. Tried 5 times, is consistent every time.
1.) open Audacity from scratch (start menu or command line) (previous state was [maximized/non-maximized] in the screen.
2.) open a project that is long enough to have content past 2 minutes.
3.) the scrollbar on the bottom is missing.
4.) [un-maximize/maximize] Audacity.
5.) the scrollbar returns.

Audacity 3.3.0-alpha-20220905
Linux budd 5.15.0-46-generic #49~20.04.1-Ubuntu SMP Thu Aug 4 19:15:44 UTC 2022 x86_64 x86_64 x86_64 GNU/Linux
Linux Mint 20.2 Cinnamon Version 5.0.7

I can’t reproduce it on Xubuntu 20.04 / Audacity 3.2.0 cc85d6 (or any other version).

I’ve read this several times and I can’t work out what you mean.
Do you mean the state of the project when it was saved, or the state of the current instance of Audacity?
Maximized or non-maximized? Is it important which?

Does the project fit in the track window?

Xubuntu XFCE/GTK has a different compositing system (from what I’ve read, I don’t know XFCE) than LinuxMint Cinnamon/GTK based on Ubuntu. This makes it seem like the way scrollbars are added by the adaption layers for each build environment may be to blame. Or perhaps a logic/sequencing/race problem between the size calculations of the track sub-windows and the scrollbar thumb size/position that makes the compositing engine believe you shouldn’t have a bottom scrollbar.

The maximized/un-maximized … un-maximized/maximixed means that if I close Audacity with the Audacity app maximized within the desktop then the next time I open Audacity it comes up maximized. Then I un-maximize and the redraw places a scrollbar correctly. Likewise if it starts un-maximized, then maximize does the right thing again.

This is when started by just menu or command line, Either one, after loading the large enough project, is missing the horizontal scrollbar at the bottom.

I just started by double-clicking the project in nemo (LinuxMint’s Nautilus) and starting non-maximized shows the scrollbar but starting maximized is missing the scrollbar.

Additionally, just now found this, when I drag the main window size around, it pops the bottom scrollbar in.

Hopefully this isn’t unique to LinuxMint, if it is, a developer with mint will have to be found, it sounds like.


I can confirm it on Fedora Silverblue 36, Gnome 42, audacity Flatpak. Scrollbar at the bottom of the window is missing if the sound is longer than the selected section on the screen.

The Flatpak version is a 3rd party build. Please try the official AppImage from Audacity. It’s available here:
According to the comment at the bottom of this bug report, it’s been fixed:

OK, thank you for answer. I tried to delete config files and test the appimage. The behaviour is same. Scrollbar appears only if I maximize and back minimize the window.

still no scrollbar here.
appimage 3.2.1, ubuntu bionic

Update: Apparently not.

(I’ve checked the latest development build AppImage, and the bug is still present. The workaround is to toggle between a maximised Audacity window and a non-maximised Audacity window.)

unfortunately, it doesn’t work for me also

I also get the same problem with the 3.2.1 appimage on KDE Neon based on Ubuntu 22.04, and I’m just posting to say the unmaximizing/maximizing trick does work here.

Note that unmaximizing doesn’t mean minimizing, nor toggling to a different audacity window, but merely hitting the maximize/restore icon between the minimize and close icons on the window.

I too am having this issue. I’ve looked at the Bugzilla db, but could not find a bug for this issue. Is there one? Will there be a fix any time soon?
Linux info:

$ lsb_release -a
No LSB modules are available.
Distributor ID: Devuan
Description: Devuan GNU/Linux 4 (chimaera)
Release: 4
Codename: chimaera

Desktop info:

KDE Plasma Version: 5.20.5
KDE Frameworks Version: 5.78.0
Qt Version: 5.15.2

Hardware info:

Processors: 4 × AMD Ryzen 3 1200 Quad-Core Processor
Memory: 15.6 GiB of RAM
Graphics Processor: GeForce GT 620/PCIe/SSE2

Audacity info:

Audacity 3.2.3

I’m loading a 1 hour +/- recording and expanding it using the Zoom In button. The scroll bar does not appear when the time line exceeds the size of the Audacity window. Adding multiple tracks does introduce a scroll bar as soon as the number of tracks exceeds the vertical window size.
Using the maximize/un-maximize trick enables the scroll bar on maximze, and it remains visible from that point on.

When Muse took over Audacity, they stopped using Bugzilla and now use GitHub Issues instead.
This issue is logged here:

The current situation has not changed since my previous post:

same here, same problem on vanilla Pop!_OS 22.04. I discovered the workaround and has been using it, but it’s just bizarre that it’s not there at the start.