Screeching and echos when I turn on Record.

Hello - I just downloaded Audacity today on my Windows 10 laptop. The first time I tried to record all was fine. Shortly when I tried again I got an awful screeching noise with an echo of anything I said. I tried removing Audacity and then downloading it again, but the noises stayed. Thanks very much for any help.

You’re (probably) getting feedback - The sound from your computer speakers is feeding-back in a loop to your microphone.

Are you trying to record from the microphone or something else?

Thank you for replying. I just clicked on the red button and did nothing else. Again, the very first time I tried that it worked fine, but no more afterwards.It does record, but with the screeching and echoes.

Two ways to get that. You have set your machine up to record internet sound instead of your microphone. Another name for that is “Anything on the Computer.” Audacity is trying to record itself.

The little Audacity recording window should be the name (or the electronic name) of the microphone.

Audacity > Edit > Preferences > Recording > [_] Playthrough (do not select).

There’s other ways, but those are the two most common.


Thank you for replying. I am still confused though. Sorry. You said, “The little Audacity recording window should be the name (or the electronic name) of the microphone” Honestly I am clueless. What recording window? And how could I make it the same as for my microphone? Do you mean the microphone on my pc at the bottom?

Do you mean like where it says Microphone RealTek audio? Or some place else?

Also, I did do as you said and went to Edit, Preferences and Recording. But I do not understand or see the two brackets with the underline between them.
Sorry, I’m not so tech savvy obviously.

You never said what you are trying to record… Are you trying to record from the microphone built into your laptop (yourself singing or talking, or something)? Or are you trying to record streaming audio over the internet? Something else?

I was only trying to record my own voice. I tried clicking off the net on the computer to see if that would help, but it did not. There was virtually no background noise The sound made after Record is like a squeaky wheel grinding round and round on a train track, cyclical. And, again, with an echo.

i think i found out part of the problem. the microphone slider is not working right. the volume slider goes back and forth easily. but the volume slider is almost always on full blast. on the few occasions when i could get the volume slider to go very low, to the left, things would work right. but then all of a sudden for no apparent reason, the microphone slider would go back to full blast again.

You need to turn-OFF [u]Software Playthrough[/u] or monitor yourself through headphones to prevent the sound from the speakers feeding-back into the microphone.

If you’re monitoring with headphones (or speakers) through the computer there is latency (a delay) which can make it difficult to “perform”. That’s the echo… Sometimes you can tweak things to get the latency down to where it’s unnoticeable, but it can be difficult to configure. Or, there are different hardware setups (interfaces or mixers) where the monitoring signal doesn’t go through the computer.

Thank you Doug! Turning off Software Playthrough did the trick. Now I can move the mic slider too. So far so good, anyway!