Says I can't open due to duplicate already running

I’m embarrassed that I’m so clueless but am so stuck!!!
I’m on a brand-new MacBook Pro High Sierra 10.13.2 and was on Audacity 2.2.1 (The newest one). I’m a beginner and this was installed during a one- day class in December. I used it a couple of times, and when I tried to open it today it says:
“The system has detected that another copy of Audacity is running. Running two copies of Audacity simultaneously may cause data loss or cause your system to crash. Use the New or One commands in the currently running Audacity process to open multiple projects simultaneously.”

But I couldn’t find another copy it anywhere nor open the one I usually use [from my dock]. I searched for everything ‘Audacity’ thru my Finder and eventually in frustration deleted anything that said Audacity, looked similar, including my desktop folders where I had already made some samples in and after class. I thought if I deleted everything “Audacity” and reinstalled it fresh, it would solve the problem…NOPE!
But, now it gives me the same message and I’m not even sure if I have everything on there correctly (I do see a new icon and pinned it to my dock). I even rebooted the computer.

Of course, I have to submit a recording tomorrow and have been trying to figure this out for almost 2 hours. YES, I am very technically challenged/ignorant. Would appreciate any help possible. I’m on the verge of tears. Thank you!!!

This is one of the corrections of that problem. I don’t know if it’s current.

It can occur when your computer shuts down incorrectly.


Thanks so much for the reply! I’m going to have to continue with this tomorrow. I’m going nuts.

Hello, the same thing has happened to me. I’ve gotten as far as the audacity.cfg file in text edit, but there’s no code/line underneath.

If it helps I have mac OS High Sierra version 10.13.16 and Audacity 2.2.2 dmg file.

This sound very similar to a problem that has just occurred for me after 6 years of problem free use of Audacity.
I get a message saying that Audacity is already running. I am running MacOS 10.13.6 and I believe the latest version of Audacity. Any advice would be greatly appreciated as I cannot use Audacity. Thanks Doug
Screen Shot 2018-08-16 at 14.51.45.png

  1. Ensure that Audacity isn’t actually running by rebooting the computer (ensure that the option to reopen windows is NOT selected).

  2. If you still get the error message, follow the instructions in this post to remove the lock file:

  3. Ensure that you have the latest version of Audacity (Audacity 2.2.2:

I’m having trouble with completing the instructions of the second suggestion.

Please describe in detail:

  • What you are trying to do.
  • What is happening.
  • What the problem is.

Please do not just leave us hanging as you did with your other post - it gives the impression that you are just wasting our time.

I’m sorry for time wasting, it’s just really hard to describe the problem. As I said, I saw you posted a solution, but I can’t seem to “lock file”.
First example is this: how am I suppose to find this in my Mac?
it said to go into
~/Library/Application Support/Audacity/Session Data but I can’t find that on my computer. Where do I go into on my Mac to find that?
Also where am I supposed to find this:
And if i can’t find that anywhere even after you give me additional advice, what shall I do then?

Copy this text: ~/Library/Application Support/audacity

In the Finder, click on the “Go” menu and select “Go to Folder”.

Paste the text into the dialog and click the “Go” button.

Open the “Session Data” folder and delete the file you find there.

– Bill

Thanks so much! I can’t believe how easy it (and quick) it was to solve with your help!
I’m sure I’ll be coming here again!
-H. Gelman

jayjayhutch, I know it has been a while from this post but, were you able to find a fix for it? I’m having the same issue and don’t know how to fix it. I deleted the app and emptied the trash but the projects I created with it still have the audacity icons. They wont open, but when I reinstall the app and try to open them, it says that the app is already running. No Audacity folder was created in Application Support (there is no folder with that name).

MacOS 10.13.6
audacity 2.3

To fix it, update to Audacity 2.4.2 Audacity ® | Download for Mac OS