Says file not found when saving

Audacity 2.4.2 on Windows 10.

After many sucessful edits audacity has crashed in such a way that I cannot restore it.

The original wav audio file was over 1 hour long. I copied sections of it into a new stero track and did extensive editing removing an echo on one of the tracks (my remote interviewees had not worn headphones).

The problem first showed when trind to export a selection to mp3. A strange error box appeared saying it could not find the file (which was odd as I was trying to create a new one). Error messages popped up as in screenshot 2

Possibly this may have followed my trying to paste a section from an mp3 encoded track into a wav encoded track or vice versa but no error was displayed at that time.

I tried to save the project but if I remember right, this did not work. I think I then closed audacity without saving the latest changes,

On re opening audacity (and choosing the latest version of my project, I think),

Automatic recovery was offered. Possibly this worked to some extent , audacity seemed to be fuctioning but when I tried to export a section as mp3 the same error occurred.

Originally in the auto recovery I chose to ignore the orphan files it mentionmed as it said they were not for this project. (By the way I had saved several versions of the project ). After two or three abortive attemts I opted to delete the orphan files.

I then decided to save my folder of recordings and project files. Although the projects led to about 30 8 min mp3 files approximately, and
original recordings were all under 30 mins, I was surprised that the whole folder was about 28Gb

I went online and followed some advice from the forum which suggested deleting a file in the users roaming audacity folder.

This did not help.

I then uninstalled and reinstalled audacity. No joy.

More research.

I then uninstalled and reinstalled audacity choosing the “do not restore settings” (or similar wording) option.

This has still not resolved the issues.

Finally I opened audacity and my latest version of the project and played out each track to an external recorder via line out (and a rode adapter). I now plan to install audacity on a desktop machine and edit from there , importing the two line out recordings.

But I need audacity to work again on my main editing laptop.

Can you help please?

I attach two screenshots. These were made by opening audacity and importing an mp3 file, then highlighting and trying to export as mp3. The first was generated on clicking the new folder button in the dialog box. The second by choosing to save in the original location.


Mark Jones
Dean Radio
error screenshot 2  save export in current folder.jpg
error screenshot 1  new folder button pressed.jpg

That’s a very long file path. Considering that Audacity data files are also several directories deep + the names of the data files, you may be exceeding Windows default maximum file path length of 260 characters.

Thank you Steve, I will investigate , that certainly sounds plausible.

Still a bit puzzled as to why the issue repeated itself with a new project in a new folder - unless that path also was too long!

I have just finished setting up audacity on a new machine.

Will investigate after the weekend.

Many thanks! :wink:

Result! Thanks Steve.

I moved the folder to desktop for a much shorter path.

This has cleared the problem.

Thank you so much, this will save me hours.