Saving usb output from a fender mustang-I amp [linux]


I posted in alt.guitar.amps.fender but I think that that group is very thin and slow. I’m trying to use Audacity-2.0.0-73.1 on OpenSuse-12.1 (and soon 12.2) to record amplifier usb output from a Fender Mustang-I . Has anyone done this? What do I need to do exactly?

Thanks a meg

From a quick look at their web site:

Mustang includes USB connectivity for high-quality, low-latency audio output,

If you plug the USB into your computer, does it show up as an audio device?

Yes, thanks for the quick response!!!
Shows up as the 4th i.e. 3, I have only crappy little onboard cards though

pactl list sources short

0 alsa_output.pci-0000_05_00.1.hdmi-stereo.monitor
module-alsa-card.c s16le 2ch 44100Hz SUSPENDED
1 alsa_output.pci-0000_00_14.2.analog-stereo.monitor
module-alsa-card.c s16le 2ch 44100Hz SUSPENDED
2 alsa_input.pci-0000_00_14.2.analog-stereo
module-alsa-card.c s16le 2ch 44100Hz SUSPENDED
3 alsa_input.usb-FMIC_Mustang_Amplifier_AF98FF303235423157216139-02-Amplifier.analog-stereo
module-alsa-card.c s16le 2ch 44100Hz SUSPENDED

Handicap: new to sound, new to Audacity, no linux guru either :slight_smile:

If you’re lucky, all that you will need to do is the plug in the USB, wait for it to be detected by the OS, then open Audacity and select the USB option as the recording input using the Device Toolbar.

Thank you. Got it going but while the Audacity recording mic volume level is all the way and frozen there, the actual recording sensitivity is low. I have to turn the amp quite a ways up to get a decent wave amplitude.

Using OpenSUSE-12.1/64 & KDE

while waiting for my earlier reply to clear…

I found a way to get around the recording level problem but it gets distorted sound cause I have to raise volume and gain on the amp all the way while turning master volume down, it’s only good as a temporary fix

Then, after recording a piece I’d want to record a new track either all by itself while listening to the first one and subsequently mix them together and/or dub unto the first one. In any event as soon as I press the record button again I get this:

Latency Correction setting has caused the recorded audio to be hidden before zero.
Audacity has brought it back to start at zero.
You may have to use the Time Shift Tool (<—> or F5) to drag the track to the right place.

twice if its stereo.

This happens if the recording starts and stalls or fails.

Assuming you didn’t enable Transport > Sound Activated Recording, it probably means your sound device cannot cope with Transport > Software Playthrough being enabled while playing an existing track as well as recording. Or maybe it cannot play and record simultaneously at all?


OpenSuse-12.2 & audacity-2.0.0-2.1.2

I just had a bit of time to revisit this issue albeit to no avail.

The volume is too low, I had to turn the amp and guitar volumes all the way up to get a crappy little trace (using the headphone so as not to blow the radiator). The sound is also staccato-like, full of crackling, & apparently at double speed. Useless.

Here’s a short 15 second sample

Has anyone on the list actually tried this amp with audacity Successfully ?

Yes there have been a couple of other users that have eventually got that amp to work with Audacity (users only generally only write to the forum when they have problems and not when everything is working fine). I don’t recall any of those users being on Linux.

The major problem there is “skipping”

There is another OpenSUSE user that we are currently trying to help on the forum that also has major problems with skipping while using a USB audio device.
The first thing is - don’t use a USB hub, the device must be connected directly to the USB port.
Next thing - try a different USB port.

I’m starting to think that there may be some underlying problem with high speed USB on OpenSUSE 12, so I’ve done a quick search on Google and there are numerous hits for “Slow USB on OpenSUSE 12”.

One suggestion from Google is to ensure that you are using the 3.1.10 kernel.

Another suggestion is that the system may be loading USB 1 drivers rather than USB 2. (see here: SDB:USB 2.0 - openSUSE Wiki)
Your amp is probably USB1 compatible so is unlikely to trigger the “device is busy” error, but may be related to poor USB performance.

I also found this bug report that relates to USB and Gnome Volume Control Applet

and this bug related to USB speed:

oh sheeeeeesh!

I never saw this one, my apologies. Appreciate you going to all the trouble of looking up the bugs

I will try this again some day but am for now bogged down with other issues with this type of guitar amp (bought another one so I now have 2) and another one related to Audacity that I will post under another heading.

I retested on 2 laptops and the mothership [asus eepc + asus g73 + amd 8-core]. The breaking up is happening only on the asus eepc and I guess that’s what I had made the sample on but the volume is still very low on all 3 computers. I have to amplify like 13db to approach peak cutoffs. That’s with a headset on the amp cause I have everything turned up for max sustain except the master volume so as not to blow the headset. If I had the amp speakers on I’d be deaf and in jail already. Fender is all soft on micro so I guess they tuned the Mustang system for the bundled windows Fuseware and ‘screw everyone else’.

So to sum up for others with the same problem

  • all amp volumes max except Master (leave that for final control)
  • guitar volume max
  • all these are the typical max sustain settings
  • headset plugged in
  • plug usb into computer, avoid hubs
  • start Audacity
  • select Mustang as source
  • select Record

You should get a thin but amplifiable band

Check the recoding levels in alsamixer
(open a terminal window and type alsamixer)
You will probably need to change the alsamixer sound card selection (F6 key) to get to the USB device - then check if you can turn up the capture level.

The device has no controls.

With all volumes full up and the headset screaming across the room I got some nice waves :slight_smile: they’re a little distorted though but usable

THEN it hit me: why bother with all this at all???

I plugged the 1/8" headset out line of the amp into the sound card mike jack and VOILA!

The usb case is NOT resolved but the problem is solved.

I just wandered back here while updating my Terratec 6fire article…

I have since sold both my Mustang amps and now have a valve type VOX instead. It has a monitoring fake-speakersound 3-pin jack but no AUX-out as such. There are other ways to handle connections to Audacity. Anyway there are connection schematics on that page that apply to the Mustangs and I will try to leave them there unless I should forget one day and erase (don’t intend to).

As far as “small but punchy” hires laptops that were hard to come by a year ago I found the Lenovo-Helix topend 11.6" i7 convertible to be without any doubt in my mind the most worthy canditate and am thinking of buying one to do the work that laptops taped to amps need to do but the little asus eeepc couldn’t even begin.

I could be wrong (never had a Lenovo yet) and if so I stand to be corrected, but I also think that Lenovo is at least among the leaders when it comes to LINUX-FRIENDLINESS!