Save or Convert to 8-bit Mono for Comcast Phone [SOLVED]


I’ve recently upgraded to Audacity 2.1.2 on my Windows 10 machine and everything works as before: That’s the good news.

I am about to record the voice announcements for a client’s office phone system. Their provider is Comcast and I can upload the files via their portal. BUT…the Comcast portal (for their VoIP Business Voice Edge phone system) only accepts files that are 8-bit Mono.

So, can I save to 8-bit mono in Audacity? I am having a difficult time finding the right settings to do this… I can find 16 bit and 32 bit but not 8-bit.

Any ideas? Or is this not possible in Audacity?

Thanks very much.

If the show is stereo, Tracks > Stereo to Mono.

Sample rate is set with the little window in the Audacity lower left. I think you can get to 8-bit in File > Export > Other Uncompressed.


No. You can only “Save” Audacity projects.

To create an audio file you need to “Export” not “Save”.

Yes you can “Export” as 8-bit mono.

First you need to ensure that the project is entirely mono. If there are any stereo tracks they must be converted to mono before you export. You can do that by either:
a) Splitting the stereo track to mono, then delete one of the two mono tracks. (see:
b) “mixing” the stereo track to mono (see:

Next, set the “Project Rate” to whatever sample rate you need. The Project Rate is in the bottom left corner of the main Audacity window.

Finally, “File menu > Export” and select the export options that you required. For example, for “Unsigned 8-bit PCM WAV”, select “Other uncompressed files” as the file type, then “WAV (Microsoft)” as the header and “Unsigned 8-bit PCM” as the Encoding. See here for more information:

Steve, thanks very much, followed your instructions and it worked. When I play the file there is a very slight static noise during playback. Wondering if the sample rate can have anything to do with that? I left the sample at 44100 (since I actually don’t know what rate I should use.)

What are you thoughts re adjusting the sample rate?

The sample rate affects the frequencies you hear. 44100 Hz lets you hear all the frequencies humans can hear. A lower rate will make it sound duller, with high frequencies removed, more like a “telephone”.

You can get more surface noise if you reduce the bit depth as you are doing.

Regardless, are you quite sure they don’t want you to choose U-Law encoding (which is 8-bit) and 8000 Hz sample rate? Most phone systems use U-Law (or A-Law), not PCM. U-Law/A-Law playback can restore the dynamic range lost when reducing bit depth to 8-bit.


Telephone systems often use a lower sample rate because it’s only for speech and sound quality is not very important as long as people can understand what is being said.
The advantage of lower sample rates are that there’s less data (smaller files). The disadvantage is that it reduces the high frequency limit, which can make the voice sound muffled and hard to distinguish betweens an “F” and an “S”.

Standard sample rates are the preset values shown in the “Project Rate” box. You could try 22050 and 11025 to see if either of those work better. If there’s no difference, you cold post a short sample here on the forum and we can take a look. See here for how to upload files to the forum:

Gale, you wrote:

Regardless, are you quite sure they don’t want you to choose U-Law encoding (which is 8-bit) and 8000 Hz sample rate? Most phone systems use U-Law (or A-Law), not PCM.

My ultimate goal is to end up with a u-law 8-bit mono wav file that I can upload via the Comcast portal for my client. So to do this, do I record initially at 8000 instead of 41000? Sorry, I’m getting a little confused on both the settings to make the recording and the settings to then export, that’s where I’m getting messed up. Can you please explain it?


Phone systems usually use 8000 Hz with U-Law encoding but they may use other rates than 8000 Hz. You would have to ask your systems manager what sample rate they require.

If they require 8000 Hz and you are only interested in low quality 8000 Hz audio then you may as well set Project Rate bottom left of Audacity to 8000 Hz.

Set the Recording Channels in Device Toolbar to “1 (Mono)”.

Then when you record the recording will already be at 8000 Hz and it will automatically export at 8000 Hz. The only change you need to make is in “Other uncompressed files”, choose “U-Law” for encoding, not “Unsigned 8-bit PCM WAV” that you were choosing before.



It worked very well! I have my recordings per instruction. One question and this may not be an Audacity thing as much as a file thing with my PC. The final exported files are not .wav…but .aiff…this is somehow related to my VLC player. How can I change to .wav format? See attached image with settings at bottom.

Thanks very much.
SVC file extension.JPG

It’s a bug in 2.1.2. The files are U-Law encoded WAV data, but they have .aiff extension in error.

Because the encoded data is correct, you could rename the file to .wav extension, but you can’t change the extension because you have Windows set to hide file extensions. To solve it, open File Explorer, click “View” at the top, then at the right, put a checkmark (tick) in the box “File name extensions”.

Then in File Explorer, select the file, press F2 on your keyboard, press End on your keyboard, then you can change the extension.

Next time you export, add “.wav” (without the quotes) to the end of the file name, then Audacity will export it with .wav extension.


I am good to go!

Thanks Gale and everyone for your wonderful detailed explanation and assistance.