Samson Q2 Mic Won't Work

Hi, again. Because you’re moderating these you can delete the previous one because I didn’t have the exact parameters you require. Here’s my problem again with the correct information:
Moderator note: done

I recently installed the Audacity 2.3.1 software on my Mac Book Air using the OS Sierra 10.12.5. I went to You Tube to watch a tutorial on the basics of using Audacity and thought I was ready to roll. I plugged in my Samson Q2 Mic and started doing test recordings/edits and everything was fine. Then, a few days ago I plugged in the Mic to get ready to record my first podcast and it wouldn’t work. I was getting error messages telling me the Sample Rate needed to be changed (code9997) or the input was bad. Once I was actually able to hit the record button and it let me talk into the Mic but all I got was a lot of hiss and a distorted voice.

I’ve done everything I can think of: reboot computer multiple times, even uninstalled and then reinstalled Audacity.

I’ve been very frustrated. Then I found this forum and saw what Mike posted a couple of weeks ago - almost the identical issues I’ve been having. Then he thanked Steve for his reply with a simple answer but I didn’t/couldn’t find Steve’s reply that gave the details on what to do. So, Steve (or anyone else) would you be so kind as to give me the step by step solution that I can use to get my system up and running with the Samson Q2 Mic? It was something about checking a certain box in security settings. I tried going into my security settings but couldn’t find anything “obvious” to check. That’s why I need very specific instructions.

I appreciate anyone’s help.

Steve Wright
Tucson, AZ

If you’ve not done so already, check this post from the Mac board:

As Popeye the Sailor Man used to say, “Well, Blow Me Down!” I was just on the phone with my computer techie son telling him about my problem getting my Samson Q2 to record and he said, “This doesn’t sound like an operating system problem; it could be that you have either a bad Mic or a bad Mic cord.” So, I thought I do have another USB cord with the exact tip to be able to plug into the Mic and the USB port, let’s try it. And, sure enough, as soon as I hit the record button the Mic worked perfectly.

My guess is that when the Mic shipped from the factory the cord they included had some kind of short in it.

Thanks all! I am glad I found this forum for any future issues that may crop up since on the Techie scale, if 1 is “I can’t find the power button.” I’m a 3, maybe a 4 on a good day like today. :slight_smile: