Sample rate and a very, very loud hiss sound

I just installed the newest version of Audacity. I have had the same problem on an older version also. In between the previous Audacity version and the most current one I put a new hard drive in my PC.
OS Windows 7 Ultimate
Converting analog audio to digital

My problem is that the second you hit record a loud and shrill hiss comes out. A ‘stab my ears out with a pencil’ hiss. Far from a background hiss. It nearly overpowers all the other sound. The audio also becomes more distorted and of much lower quality than it should be.
Even if I hit record and have not started playing the cassette or record that hiss is there.
The only thing that has a major effect on this problem is changing the sample rate on my computer (not Audacity). I will continuously switch from one sample rate to another and another and eventually this hiss ends.
Despite having put in a new hard drive and different operating system on this computer I still believe the problem could possibly lie in the computer and not Audacity.

Are you using a USB cassette player?
What settings do you have in the Device Toolbar?

Yes, it is all USB

Audio Host - MME
Output - Speakers
Input - Microphone USB
Channels - Stereo

To give you an idea, with the input volume all the way up this hiss will hit a minimum around -30 decibels.

I presume that so far you have stopped the recording immediately (before actually trying to record anything) - am I right?

What I suspect is happening:
For some reason, Windows seems to often set the record level of USB devices way too high, and it is often necessary to turn down the recording level in the Windows Sound Control Panel to a ridiculously low level (almost off) in order to get a proper recording level. There may also be a “microphone boost” setting in the Windows Sound Control Panel - if there is, set that to zero or off.

Turning the volume down just quiets the hiss and the recording.
I am starting to think somewhere in there is a communication problem with software.
I was hoping it is user error, cause it can be extremely obnoxious when killing that hiss takes 15 minutes of changing settings around til you get the magic touch.

I presume that the noise goes onto the recording?

Try this:

  1. Go into the Windows Sound Control Panel and set the USB device as the default recording device.
  2. Open up the Windows Sound Recorder and make a test recording from the cassette.

Does that have the noise?

If not:
3) Open Audacity and set the recording input to “Microsoft Sound Mapper” in the Device Toolbar.
4) Turn off “Software Playthrough” in the Transport menu (if enabled)
5) Make a test recording from the cassette.

Does that have the noise?

If not:
6) Enable “Software Playthrough” (if it was enabled before step 4)
7) Make another recording from the cassette.

I’ll give those suggestions a shot today.
Even when I do eliminate the loud hiss there is still a very faint high pitch tone the background.
I will try running RCA cables in and some different turntables too.