right click file to open / Audacity 3.1.0 / Windows 7

I’m working on an old laptop at the moment with Windows 7, I’ve upgrade to Audacity 3.1.0 (I read 3.1.0 is the last version that will work on Windows 7).
With the past versions of Audacity I have used if I right click on a .WAV or .FLAC under ‘open with’ Audacity shows up with other music software like
Adobe Audition etc., and I can select Audacity (it’s much faster than going to the open tab then searching through all the files), but with this 3.1.0 Audacity I’ve just downloaded when I right click on a .WAV or FLAC and go to ‘open with’ Audacity isn’t in the list…
How do I get it to show up and work?

If so you’ll have to browse for it in …

C:\Program Files (x86)\Audacity

[ BTW you can just drag’n’drop audio files into Audacity ]

I’d actually already tried browsing for it, and when I click on either the desktop icon, or go in C:\Program Files \ Audacity and click on the icon there it doesn’t do anything, the browse box just closes and when I try again to open a .WAV or .FLAC by right clicking and selecting ‘open with’ Audacity still is not there.
Thanks for the drag/drop tip!, I did not know that, but for things like I’m currently working on I’d prefer to be able to right click and ‘open with’.

Please be aware that Audacity no longer officially supports Windows 7 because Windows 7 is obsolete. Audacity “may” still work on Windows 7, but the development team do not test on Windows 7 and will not fix any bugs that apply only to Windows 7 (If / when Audacity stops working on Windows 7, it’s unlikely that anyone will fix it).

For additional information on saving Open With settings under Windows 7, do a Google search on: “windows 7” “open with”

Also, check that you do in fact have a 64-bit machine. You might have two versions of Audacity, one (for 64-bit) in C:\Program Files.…; the other (for 32-bit) in C:\Program Files(x86).…

To confirm which 3.x.x version you are running, Do Help > About Audacity. To confirm that you are running the 64-bit version, Do Help > About Audacity > Build Information , and look at the 3rd or 4th line. My computer, for example, says “Build type: CMake Release build (debug level 1), 64 bits”.

I’ve realised somethings going wrong with Audacity 3.1.0 and the ffmpeg library when opening a .MKA audio file.
I did a test and used an audio file .wav and made a .mkv video, I then demuxed the video so I have the audio as a .mka file.
I then opened the .mka file with Audacity 3.1.0 using the 64bit ffmpeg library 3.1.0 directs you to download, and saved as .wav.
The audio Audacity 3.1.0 output is changed from the original file, I inverted and did a mixdown to cancel out any matching audio,
the right channel is quite different to original channel.

I then did the same with Audacity 3.0.0 and used the ffmpeg libary 3.0.0 directs you to, opened the .mka and exported as .wav, when I inverted and
layered one of the other as mixdown, it was silent, meaning that the audio was the same as the original file - as it should be.

So something isn’t right with Audacity 3.1.0 and the 64bit library it directs you to, unless this is a problem because I’m using Windows 7.

For now I’ll keep using Audacity 3.0.0 on my old Windows 7 laptop, the only bug I know with that set up is the “Failure to open database” bug when using macro / batch process to speed change.

I’m using Windows 7 pro service pack 1, 64 bit, Audacity 3.0.0 doesn’t say 64bit, but Audacity 3.1.0 does say 64 bit (I did my tests with the version of
Audacity I wasn’t using at the time completely uninstalled and all associated folders deleted).