Reverb Effect when recording

I’m using the newest version of Audacity (for the first time), on a HP pavilion laptop with Windows 10.
Following the brilliant advice on here last year, I have a Behringer U-Control UCA202 through a small Behringer Xenyx502 mixer.
When I click to start monitoring to ensure the levels are ok, there is reverb effect through my headphones (which are usually plugged into the U-Control).
The reverb effect sound is slightly worse when I hit the record button, making the recording of my own voice to be quite impossible due to the reverb sound through the headphones.
Playback of the recorded audio is fine, no reverb effect at tall.
My Mic goes into the mixer, a lead from the Output goes into the U-Control and that goes via USB into the laptop. Its just as I used to do things prior to switching to the newer Audacity.
I can’t work out how to stop this, which is I guess a duplication of the audio, actual and monitor? I tried the monitor switch on the U-control with no effect.

Edit > Preferences > Recording. Make sure Overdubbing is the only thing selected.

You should be listening to the UCA-202 with your headphones and the Monitor switch on. That’s the only way to hear yourself in real time without the echoes.