Reverb and echo when recording and on playback

About I month ago I found that I could no longer record so I downloaded the latest version of Audacity 2.3.3. Now when I try to record from Spotify or Youtube the recording has nasty echo and reverb on it and it is also on the new playbacks of the new recordings. The existing recordings which were done before play back without problems. I have tried switching the effects on and off but made no difference. I have checked sound settings on PC but could not find anything which made a difference Please play the sample below. Please help. This problem is driving me crazy.

I am going to do everybody a favour and reply to my own question. I eventually uninstalled the latest version of Audacity and installed version 2.2.2. This functions normally so this proves to me that the latest version of Audacity is NO GOOD. Thank you and good night.

Sorry that no-one got back to you sooner. Your original post seems to have slipped through the cracks. (Audacity is developed, documented and supported by volunteers, and we only have a few contributors but millions of users).

The problem in the audio sample that you posted appears to be a settings problem. If you want to try Audacity 2.3.3 again, ensure that the “Reset Preferences” option is selected during the installation. This will ensure that the sound settings are reset to the correct defaults.

I can now answer my own question properly. I went into EDIT then PREFERENCES then RECORDING and I unticked SOFTWARE PLAYTHROUGH OF INPUT.
This solved the problem instantly.

FWIW, resetting preferences would have turned off Software Playthrough (Software Playthrough is off by default).
Glad to hear that you have it working. :slight_smile: