Repeatedly getting garbled audio while recording.

I keep getting garbled recordings using audacity.

Here is an example:

Not ever recorded track is garbled. I thought it only happened when I left a browser window open, or a media player. Today though I’m getting garbled recordings and I don’t have anything open.

I am using version 2.0.2 or audacity. I have windows 7 home premium 64 bit and my computer is relatively fast. The cpu and memory are never any where near maxed.

Some part of the system is not going fast enough to handle real time audio. Each of those little ticks and crunches is the system gasping for air. If you have a new or relatively new computer, then we need to look somewhere else.

Did you run your USB microphone through a hub with your keyboard and mouse? Don’t do that. Audio doesn’t go through hubs well. Audio USB should go direct.


I am using a usb microphone. I had it plugged into the ports on the front and I thought that might be the problem so I moved the microphone to the ports on the back. That’s where it is now.

Also take a look at .


I closed most processes. The only processes open were using very few resources. The only windows open were audacity, notepad, windows task manager, and calculator. I watched the windows task manager while recording, and the cpu never went over 20%. The memory stayed around 1 gb(out of 3). No new processes started while recording.

Still, at a little after 2 minutes…maybe 2:15 the garbled audio started again. It usually starts around 2 minutes or shortly after.

Ok…I read the website you linked to. I loaded up dpc latency checker and it’s fine most of the time but gets occasional red spikes. I guess that means that one of my drivers is causing problems? I’ll try updating them all and see if that helps.

Check out LatencyMon. It can help you pinpoint which driver(s) that are causing problems.


Another one to try:
Start > Settings > Control Panel > System > Advanced settings.
Click on the Advanced tab, and under Performance, click on Settings.
When the Performance Options window opens, click on the Advanced tab and for Processor Scheduling, choose “Background Services.”
This change alone cut latency in half on one of my systems.


I think I’ve solved it. Thanks for all the help.

I looked for updates to all my drivers and the only one I could find was an updated driver for my nvidia chipset. I installed it and it didn’t seem to help the dpc latency issue.

A while back I installed a creative sound blaster x-fi music to see if it would help me get my latency down so I could do realtime monitoring. So, last night I took out the x-fi and switched back to the built-in audio. I upgraded the realtek hd-audio drivers and restarted.

The dpc latency seems to be gone!

If I had tried latencymon from the beginning it might have told me it was the x-fi drivers. I had my suspicions just because it’s creative.

I’m still getting a lot of pagefaults with really long resolution times but I’m going to assume that’s normal.

Realtime monitoring probably isn’t possible on this computer with windows 7 unless I get some other hardware or use a different OS. I’m just happy to be able to record again without having to worry about whether or not the track will be garbage when I finish.

I added a link to LatencyMon and the tip about processor scheduling to . Thanks for the tips as always, Ragnar. That said, Latency Mon is probably not the easiest tool for a computer beginner to use.

So-called page faults are indeed normal.

If you have a lot of installed RAM (at least 6 GB or more depending on what you use your computer for) and problems recur, you could try removing the paging file.

Windows isn’t a real-time system. But it can get close enough for audio purposes with an ASIO-enabled sound device. Unfortunately Audacity as shipped does not support ASIO protocol due to licensing issues. Please see this page for more: .


Ok…if I leave media monkey or firefox open I still get the laggy audio even though I still have plenty of resources. Is this normal behavior? Should I just force myself to remember to close these programs before recording, because it’s normal or is there something else going on? It would be nice to be able to leave these programs opening because I use them for reference when I’m recording.

Also, the only thing in “directories preferences” is the location. There is no option for “audio cache” or “record to ram”.

Quite possibly. You can’t have more than a few tabs at a time open in Firefox or it will slow the whole computer. If you want lots of tabs, ensure you have latest Firefox. In Tools > Options, choose “Tabs”. Make sure “Don’t load tabs until selected” is checked (has a tick mark).

Did you try Ragnar’s tip ?

Audio Cache was removed in 2.0.2 because it had a tendency to cause crashes.

If I understand it, you only have 3 GB RAM which is below Audacity recommended requirements for 64-bit Windows 7. If you can spare 1 GB of RAM, set that aside as a RAMdisk and set the Audacity temporary directory to the RAMdisk. That gives you 50 minutes of stereo recording at Audacity’s default 32-bit float quality. As soon as recording finishes, save a project to your hard drive (not the RAMdisk, because it may not have room for editing the recording).


I still get garbled audio even when nothing is running, and I’ve shut down all possible processes in the task manager. I have processor scheduling, set to “background services.”

There is nothing using up resources and no reason for audacity to skip and sound garbled the way it does.

I’ve lost too many good recordings. Though I don’t want to, I may have to find a different recording software.

I would strongly recommend making some recordings with another program, if only as a process of elimination.

Did you try increasing “Audio to buffer” in the Audacity Recording Preferences yet? Try 300 ms or more.