Repeat Recording

Hi, I’ve just bypassed my desk and connected my Korg Kross directly into my PC. I have the correct Korg drivers. I open Audacity 2.3.3, generate a click track, but when I’m ready to record my keyboard track on the recording track below, it is also recording the click track above. Is there a setting whereby each additional track I record only records what I’m playing rather than an accumulation of all previous tracks each time? I have mic set to Line(KROSS2) and playback is Headphones (KROSS2).Obviously, I have to have the mic set to the Korg as the recording device but if I change the playback from the Korg,( where my headphones are connected) to the PC or the speaker system connected to the PC, then I can hear what was previously recorded but not what I’m playing and vice versa! I have no issues with this going through my desk, but it was generating some unwanted hiss and sibilance, so I thought to cut out the problem and connect directly to the PC/software which, of course, raises different problems! Would appreciate some guidance on this please. Many thanks.

Is the recording device (you call it “MIC set”) really named “Line (KROSS2)” or is the name longer? Please, report the whole name.
What do you mean with “desk”? What is it exactly?

Maybe, that the recording device (you call it “MIC set”) has the word “loopback” in its name? This causes that the computer audio out signal is routed to recording input. select a recording device without the word “loopback” in its name.

A second source for the problem could be, that the KORG itself routes the computer signal back to the computer. Do you use one USB cable to connect KORG and computer? Or two audio cables?

Hi, there is no ‘loop’ in the drop down options for the recording device or the playback. I have the ‘line (KROSS2)’ option on both recording device (microphone symbol) and playback device. When set to both of these, I hear the keyboard while it’s recording via my headphones connected to the Korg, but I don’t hear the click track as playback is set to KROSS2 also. When I change playback device to the laptop sound device audio, I don’t hear recoding track through headphones, but the click audio is coming from the laptop speaker. I need a way of hearing both the track I am recording AND whatever I had prerecorded, at the same time through the headphones. I connect PC or laptop via 1 usb cable from the keyboard. Previously, I was connecting the Korg via jack to jack into my Allen & Heath Zed 16 FX line channel, then via usb from desk to PC. This worked well, but was having hissing issues on recordings. Was finding it increasingly frustrating to get a perfect balance between adjusting the channel gain, fader, aux level with the recording level on Audacity. Really difficult! I can do ‘noise reduction’ on a recorded track before ‘normalising’ and that helps but it’s such a lot of fannying around. I thought maybe if I cut out the source of the hissing (the analogue desk) and go direct from Korg to PC or laptop, it might make things easier! Lol.

…I should add that I can hear through the H/phones both the previous recorded track (click/other) and what I’m playing to record another track when the recording device AND playback device are set to the Korg (line (2 KROSS2) but the new track includes all previous tracks! For example: I lay a click track then I record a keyboard track underneath but that new track is also recording the click track when, obviously all I want is the keyboard.

It looks like the KROSS itself is routing the computers out signal back to computers recording in.

So the best solution would be to give the combination via the Allen&Heath a second chance…

Did you really work with the actual driver?
A friend of mine uses the same mixer and has no problems.
Try to record something at a very low volume. In AUDACITY the recording is already OK, when the signal is around 0.25. This equals -20dB:
Is there still the hissing?

Hi, I tried going through the Allen&Heath again and discovered that it really doesnt matter too much what levels I set with their gain and fader (within reason) as long as I reduce the recording level on Audacity to no more than 80%. Hardly any hissing! Thanks for your comments.