Removing silent clips after adding effect

Hi all,

I’ve raised my question on reddit, but I think this might be the better place afterwards. As I’ve never put a lot of time into Audacity, beside adding an effect to a file and exporting it afterwards, my knowledge about it is pretty low.
So I currently need to add an effect to several hundred files, which is fine, I add 20-50 files as separate tracks, add the effect to all of them via Ctrl+a and wanted to export each track as separate file again …
Now comes the problem. After the effect is added all “shorter” tracks got a separate silent clip after the initial clip of that track, in order to match the length of the longest track.
How can I disable this clip creation by adding the effect? or how can I quickly remove all separate silent clips, which are in at the end of all shorter tracks without clicking each one by one and delete them manually?
Truncate silence also removes silence within the correct changed tracks and not the “empty” clip

This topic was automatically closed after 30 days. New replies are no longer allowed.