Removing repetitive clicking from a damaged .wav file

Version number: Audacity 2.1.2
O.S.: Windows 10


I was recently asked by a friend to recover a .wav file containing an interview recorded on a cheap dictaphone. The file was either not playing, or played as a blank file with no length. Importing it as raw data into Audacity allowed for partial recovery - the interview was there but distorted beyond listenability. After some digging it turned out that the header of the file was damaged. I was able to recover it with a hex editor, using an existing, functioning recording as a template. Unfortunately while the speech is discernible, there is a loud, repetitive, rhythmical clicking noise for the entire duration. I’ve tried to use Audacity’s noise reduction, click removal and equalization features - to no avail. Because I have no experience with audio editing or data recovery I’m at a loss here. Here is a dropbox link to a short fragment of the interview (if a longer version is necessary I will upload it asap). If anyone could look at it and point me in the right direction to remove the clicking noise - whether it is a specific function in Audacity or more hex editing - I will be very grateful.

You can’t easily fix what you posted.

If the original WAV contained valid uncompressed audio but was just missing its header then Import Raw Data should work if you know the exact file data such as encoding, byte order and offset.

If you replaced the header correctly then that should also work but that is harder to do.

I would go back to the original corrupted file and import it raw according to the file properties of a known working file from the same dictaphone. You can download “MediaInfo” from to see the information for the known working file. Get the MediaInfo version without installer, because the installer may have malware or adware.

If MediaInfo says the WAV file contains compressed audio like MP3 then Import Raw Data will not work.


Thanks for the reply.

Mediainfo CLI came up with nothing for the original, corrupted file, i.e. it only returned the filename and filesize.

The file I managed to recover with a hex editor and the other working recording returned the following data:

Complete name : v002.wav
Format : Wave
File size : 11.0 MiB
Duration : 47mn 54s
Overall bit rate mode : Constant
Overall bit rate : 32.0 Kbps
Writing application : SIGMATEL

Format : ADPCM
Codec ID : 11
Codec ID/Hint : Intel
Duration : 47mn 54s
Bit rate mode : Constant
Bit rate : 32.0 Kbps
Channel(s) : 1 channel
Sampling rate : 8 000 Hz
Bit depth : 4 bits
Stream size : 11.0 MiB (100%)

The exact compression of the files that recorded correctly, is (according to the VLC player) IMA WAV ADPCM (ms), which as far as I understand it, is not fully supported by Audacity.

When I tried to import the raw data from any of the files - working or broken - I used: VOX ADCPM format, default endianness, mono channel, no offset and 8000 Hz for sample rate. The effect, like I mentioned in the original post, is a file with a highly distorted, robotic speech but with no clicking (for all - working, hex edited and corrupted files)

I feel like I’m way out of my depth here so any help would be greatly appreciated.

Thanks guys for all the help - fortunately I’ve been able to resolve the problem myself. It seems that while hex editing manually I inserted some additional data after the header which amplified the clicking. By using a different hex editor I was able to copy a working file’s complete header and paste it into the corrupted one which fixed the problem.

If anyone needs some guidance about what the .wav file header looks like, I found this site really helpful:
I used the HxD hex editor to copy and paste everything up to and including the hex values for DATA.

On a side note - could anyone explain why both audacity and adobe audition distorted the raw data imported from the corrupted file in the same way (i.e. changed the speech to a distorted. robotic voice) even though all the audio parameters seemed to be correct?

Almost certainly the raw data import is incorrect because VOX (Dialogic) ADPCM is not the same as Intel (IMA) ADPCM.

VOX ADPCM is actually a headerless format by design.