Regular popping during playback


I’m using Yosemite on a Mac with 2.53 GHz dual core, 4G of 1067 MHz DDR3 memory, at least 75GB avail HD storage; and Audacity 2.1.1, which I just downloaded about a week ago for the first time. (I’m sorry, I can’t remember which I obtained, but I think it was the zip file.) I’m using Avid’s Mbox Mini for my interface.

I’ll state up front that I don’t know as much as most on this forum probably do about my Mac, recording equipment in general, or any DAW, but I’ve been a mid-range ProTools user (not fluent in it by any means, but have been using it for at least 6 years now for all my own projects, so I know how to use all the basics of the DAW), and just decided to give Audacity a try on the recommendation of a fellow musician.

I just tried recording a simple vocal track. Upon playback, I get a regular popping/clicking - by regular, I mean it sounds like a small helicopter all up in the vocal itself. Then I tried importing an audio track and playing it back. Exact same result.

I have my Mbox set as my input/output on both my Mac.

I tried going into Audacity’s preferences and changing the “Audio to Buffer”, starting at 0 and working my way up in increments of 10 before I finally reached 80 as the best playback I was going to get. No change in result re: the popping/clicking.

I’ve looked around the forum a little more than these two suggestions, but I’m at a loss for what else to try next to resolve the issue. It could well be something simple that I’ve overlooked or wouldn’t know to try… Suggestions?

Thanks in advance.


There is one. I believe the MBox and Avid both support ASIO software interface. Audacity doesn’t. So the device is working with default Mac software, support and drivers, not the one it’s actually looking for.

That may be a good place to start asking questions.


@Koz: there are no ASIO drivers on OSX. There has been an experiment, many moons ago, but it seems nobody needed it.

Supposing you did an OSX upgrade and not a clean install and you probably had Protools in a version below 11.3 installed before:

Look for the Avid…Protools…transport…something Kernel extension in

/System/Kernel extensions/

Delete it. Restart your Mac.

  • either use “Go to folder” under the “Go” menu in the Finder, or the Terminal. Otherwise, you might need to make this folder visible first, I think.

Is it a third-generation Mbox Mini? If so, have you installed the latest “1.3” drivers from

Note that if your Mbox control panel also has buffer settings, these may interact with “Audacity’s Audio to buffer” settings. Depending on the Mbox buffer setting, you may have to increase Audacity’s “Audio to buffer” above the default 100 setting.


Thanks for the suggestions. I apologize for the complications that come from me not knowing enough about some of these things…

Okay. I installed the Avid 1.3 drivers. Still having the issue.

On a related note, I did check to make sure that I was NOT hearing the popping/cracking when I set input/output to default Mac I/O. So it IS an issue with the interface or PT software. That said, I DID do the OS upgrade, not the “clean install”. I’m honestly not sure how a clean install is done.

I’m not comfortable with or the command line at all…so as far as using the Terminal or deleting anything that way, I’d need step by step instructions.

I haven’t bothered UNinstalling PT at this point. Do I need to try that first?

Have you tried the suggestion of using higher “Audio to buffer” values, or looking at latency / buffer settings either on the Mbox itself or in ProTools?

It is better not to use abbreviations. Is “PT” ProTools?

You will have to use the terminal at least once if you want to do what cyrano suggested. I would suggest you use the terminal to show hidden files and folders, then you can use Finder to navigate and delete system files. Follow “Show/Hide Hidden Files the Long Way” near the top of

If “PT” is ProTools I suggest you look first if it has settings for buffer or latency.


Just to clarify, “PT” = ProTools.

No. I don’t see any such option when opening up System Prefs for the Mbox, and I can’t currently open ProTools at all to look for such as I’m given the incompatibility-with-Yosemite error message when I try. If it’s even possible, I don’t know how to change these settings without being able to start ProTools in Yosemite.

Ok. Thanks for the link.
On that note, the question I should have asked is: What is that file (kernel?) that cyrano was referring to? What does it do?
If I go through the Terminal, find and delete the file suggested, will it affect anything about the ProTools files still on my Mac? My files ARE backed up onto an external hard drive, but I don’t want to go deleting anything that I don’t know what it is or how it may affect other files or programs.

Further along this line, does anyone using Audacity also have and use ProTools on their Mac? I realize that it may be that having/using one may alleviate one’s need to have/use the other, but… Assuming you change necessary settings & such when using one or the other, the two shouldn’t be mutually exclusive to run on the same machine and with the same hardware, should they?

Thanks again.

That file* is a “kernel extension”. It’s made by Avid and serves one purpose: reducing latency between PT and an Avid interface. It shouldn’t affect other DAW’s or other interfaces, but it does under newer systems. It was introduced in 10.4 and abandoned a little while ago, I think under Lion (10.7). There’s very little info about it from Avid. It also doesn’t get installed on every PT setup.

A “kernel extension” is a part of the system software that “extends” its capabilities. It could be a device driver (printer, webcam, network port…). Most of these device drivers are made by Apple. It’s rare these days that fairly standard hardware needs a kernel extension.

The kernel itself is THE system. It contains everything that makes a Mac work and that is common to all Mac hardware. To put it simple: it knows about all the hardware everyone needs, such as screen, keyboard, mouse, ethernet, Wifi…

  • Wish I could remember the exact name, but it’s been at least a year since I encountered one in real life.

You could try higher Audio to buffer in Audacity. You are probably going to have to fiddle with that whether or not you delete the ProTools kernel extension.

Also make sure you have the Audacity project rate (bottom left) set to the same sample rate that the Mbox input and output are set to in /Applications/Utilities/Audio MIDI setup.

Is this a portable Mac that comes with a screen and battery? If so you may want to upgrade to El Capitan as soon as it is released later this week. A few users who have had popping playing from Audacity to external interfaces have said that El Capitan suffers less from this than Yosemite or Mavericks.


Thank you, Cyrano!! Now I understand.
It’s been since high school (15 years) since I had to mess with a command line, terminal, any kind of programming, etc. Too long to be able to remember.

When I got the best possible sound at 70, I continued going up in increments of 10 to 150, then jumped in 25’s to 300… Eventually, my audio went away altogether.

Check. Done, but I’ll go back and make sure.

It’s a MacBook Pro…?

I asked because MacBook Mini’s (mains only, no battery, so less aggressive power management) seem to suffer less from clicky playback to external devices.