Region label sound data overlaps

I’m using version 3.3.1 on a Windows 11 laptop.
When preparing an LP’s tracks for Export/Multiple, the labeled tracks overlap. I take the following steps:

  • Select the region of data to label. This will entail zooming and using the clip-drag tool to accurately select the range.
  • Control-B to start the labeling process.
  • Enter the name of the track followed by Enter.
  • Select the range of the 2nd track and repeat the first 3 steps, using zooming and clip-drag. The first track appears to overlap the second.

What is going on here?

Yes. So it sounds like you are not doing something right. Perhaps if you were to include a screenshot, it might better describe exactly what is going on here.

One way to create accurate region labels without having to do all the fancy acrobatics it to first create point labels at the start and end of every desired audio section.


Then, Tracks > Add New > Label Track. Now drag the new empty label track up by the empty space in the Track Control Panel at the left. So now the upper and lower label tracks are switched.



Now swipe across the audio between the first two labels (yellow guide lines will display when the cursor exactly matches your existing point label. Ctrl-B to create the region label. Of course you will want to enter text. After you create all of your region labels you can delete the orignal label track.



In response to your request to send screenshots, here goes:

  1. Import a wav file of an album that I recorded with Audacity.

  2. Set point labels for the first 2 songs using control-B.

  3. Using the clip handle drag bar, advance to the next song. Notice that the range in the label track for the first 2 songs has advanced with the movement of the drag bar. This is what’s causing label overlap for me:

PS: the screenshots are not showing up in my edit window for my reply. I hope they get sent.

If you move the track, then the labels will no longer be associated with the correct audio positions.

There are two ways out of your dilemna:

  1. Use Track > Sync Lock tracks. This will lock the labels to the audio as long as you keep them locked together. Personally I don’t use this. There is a possibility that audio could be moved prior to time 0 which could cause other issues.

  2. Use the Windows-type scroll-bar at the botton of the track panel to move the entire contents of the track panel left or right. This is what I do - in conjunction with the “zoom” and “fit” buttons. I understand that in Windows 11, this scroll bar may be harder for some people to use - if you find this so, click Start > Settings > Accessibility > Visual Effects > Always show scrollbars.

BTW, you can exit Audacity’s “Envelope Tool” mode, by pressing F1.

Problem solved with your Method 1! Thanks so much!

I did as you suggested for Method 2, setting the Accessibility setting to “Show all scroll bars”, but I’m still unable to find the scroll bar at the bottom of the track panel that you mentioned.

Is this it:?

Got it now. Thanks so much for all your help.

This topic was automatically closed after 30 days. New replies are no longer allowed.