RegCreateKeyEx failed code 1450

Received this error when installing Windows version 2.1.2 of Audacity.

Exactly when does this occur, during installation?

Is part of the message that “Insufficient system resources exist”?

Did you install Windows 10 over previous Windows?

It’s possible installing CCleaner and running its Registry cleanup tool might help.

But in case the message is spurious, have you tried installing Audacity as an administrator (right-click over the Audacity installer)?



Gale

It happens at the very end of the install.
Yes, the “insufficient” was part of the message.
No, it was a fresh install of Windows 10. I am part of the beta testing.
I will try CCleaner, and run the install as an administrator.

Will get back to you with the results.

If you are running “Insider” builds they are not official releases of Windows and so Audacity does not officially support them. If so it may be an idea to report the issue to Microsoft too.

You can always use the ZIP version of Audacity which does not require installation.


Gale

I went to MS support first, and they pointed me to Audacity. Still haven’t had the chance to try the CCleaner.

OK, ran CCleaner, and tried to reinstall the 2.1.1 version as the admin and got the same error. I’ve attached a jpeg file that is a capture of the entire error message.
Audacity Error.JPG

You can try installing the release version of Windows 10 on a separate partition and see if the same problem happens. If not then it is apparently a problem with the Insider build you are using.


Gale