Red thumbtack in Timeline [SOLVED]

I have a recording problem: There’s a red thumb tack that won’t let me record, or it will only let me record to a certain point. If I click on it, it moves back to the beginning of where the recording should start, and then it won’t let me record anything. I have never had this problem before. I don’t even know how this red thumb tack came into existence. Please help.

The “red thumbtack” is the “recording cursor” when the “playhead is unpinned”.

Pinning or unpinning the “playhead” can be changed by clicking the button on the left end of the “Timeline ruler”.
More information here:

The default for whether the playhead should be pinned or not, is set in Preferences:
“Edit menu > Preferences > Tracks → Pinned Recording/Playback head”

If you still have a problem recording after turning off the “pinned” playhead, then the problem may be unrelated to the playhead being pinned, in which case, please ask again with updated information about the problem.

Thank you for solving my “Red Thumbtack” issue.

You’re welcome. Thanks for telling us that the issue is solved.