Red clipping lines but no waveform at 0db

I noticed after “Mix-Render” some red clipping lines but the waveform was not near 0db. Even with a really close zoom in no wave form near 0db

Which version of Audacity, on which operating system? Can you post a screen shot of the track showing the red clip lines with no waveform clipping?

– Bill

Note that “0 dB” can be at either the top or at the bottom of the track.

I am using 1.3.12 with Xp Sp2


A much closer view

Do they vanish if you Amplify (reduce) the show something tiny like -0.1db? The clipping indicators are a little magic because lots of things happen at “0.” For one thing 32-bit floating audio doesn’t clip at 0dB, and another is audio at 0dB isn’t necessarily clipping. 0dB is a valid place for an audio peak to be. Anything over that is not.


Did you use the volume control or the pan control on the left hand side of the timeline? They cause the timeline and the show to go out of reference with each other. It’s possible to amplify the show with that tool and cause intense damage, but the timeline blue waves will be perfect.

It occurs to me you may be suffering from sampling errors. Even at 32-floating there are volume errors and all you need is one error that causes the show to think it went over 0dB to trigger the red bars.

Did you tell us which version of Audacity you have? If you’re using Audacity 1.2, you should stop that and upgrade to Audacity 1.3.12 right away. Development, patches, and error correction on Audacity 1.2 stopped a long time ago. Even if we do find the error, you’ll be in Audacity 1.3.12 anyway.


I am using 1.3.12

The posted image was amplified with gain at least 7db. No pan was done on the track.

I just tested using Amplify with -0.6 needed to remove clip lines. The reduction causes a slightly detectable volume lowering

Listening with the clip lines, I can not detect any degredation of sound quality.

Could you post an image that is zoomed in even closer so that it shows the individual samples.
Do the red lines disappear and then reappear if you disable “Show Clipping” (View menu) and then enable it again?

I am feeling like a yutz right now. The red clip lines were masking the waveform. I turned off “Show Clipping” (did not notice this selection until Steve mentioned it) and there was a waveform at 0db. Sorry for wasting everyone’s time

No problem, thanks for getting back to us.