Recovering recordings without aup file.

Hello, this is not a question, I just wanted to share my experience, and perhaps it can be useful to anybody.

I recorded at the same time 4 mono signals (more than 30 minutes), and when recording, audacity crashed.
I had an empty .aup file, and hundreds 1MB .au file whis strange names.

This help did not work for me:

Tryng Append import, it was totally hazard, so I had to order them before.

For recovering.

  1. I ordered them by date.
  2. I used Konkeror for massively rename them starting by Audio1000 (if starting by 1, I had problems later)
  3. After that, I had 4 files with the same datation, another 4 files created a few seconds later, and so on.

I tried to import them, but it was crazy, so many files. If I used theappend import pluging, I had several seconds for each channel. So I need split each channel before.

For that I programmed next script using python (sorry it is in spanish):

import os
import shutil
for nombre_archivo in lista_archivos:
  if nombre_archivo[0]=='A':
    if numero_microfono==0:
      shutil.copy(nombre_archivo, "000"+nombre_archivo)
    elif numero_microfono==1:
      shutil.copy(nombre_archivo, "111"+nombre_archivo)
    elif numero_microfono==2:
      shutil.copy(nombre_archivo, "222"+nombre_archivo)
    elif numero_microfono==3:
      shutil.copy(nombre_archivo, "333"+nombre_archivo)

After that, I could use Append import, and importing just 000*files without problems.

Of course, perhaps there is another easy way for doing the same, but it worked for me. Perhaps instead append import, one everything was splitted I could have used this shell script ( but, it seems to work fine with mono files.

Thanks. I think a long time ago, I successfully used the steps “Linux command-line alternatives for timestamp sorting” then Append Import on a small number of files, possibly only one track though, whereas you have four tracks. Did you use the latest version of Append Import?

If you rename the files in an alphanumerical sequence, it is probably better to use the “1.2 Recovery Utility” to merge them to WAV files.

It may be better to find out why Audacity crashed and could not recover the recording. What version of Audacity are you using and where did you obtain it? What version of Ubuntu? Audacity 2.0.6 supplied by Ubuntu is very buggy because they built it with a version of wxWidgets that 2.0.6 does not support.

Most users on Ubuntu up to 15.10 should uninstall their packaged version of Audacity and install the 2.1.2 PPA of Audacity from

What recording device are you using? Does it support Linux and have you looked for community-provided drivers for it?


It may be better to find out why Audacity crashed and could not recover the recording.
Totally agree.

What version of Audacity are you using and where did you obtain it?
I am not sure, I just took an old small pc I had with an old ubuntu 12.04 (no internet, just some games for children), totally out of date, and I tried at home and it worked fine. I took the hard disk for installing it in another pc and recovering them faster, so I do not know, but it is so old that it has no interest. Anyway, whrn I knew, I will came here and answer.

What recording device are you using?
Behringer UMC404HD. It worked at home for ten minutes, and I did not test it for more time (my fault). It is class compliant, so it does not need specific drivers. I use it a lot ot times with my desktop pc without problem.

I did not use jack, directly ALSA with 4 channels @ 44100 sps.

About the 1.2 recovery utility, I will try it, buit I am not sure if I will be able.

Thank you.

The Audacity version can be found at Help > About Audacity… . It is probably Audacity 2.0.0 if you obtained it from Ubuntu - it is really old now.