Recover project - Audacity 80.156.6


Unfortunately, I have a corrupted data base file. Running the steps in audacity tool gives me a recovered .aup3 file. However, once opening it says I need a newer version of Audacity (running 3.2.3).
Once investigating the terminal, the flag “-recover_db -recover_project” gives me the following output: “Project requires Audacity 80.156.6 \n Unsupported project version”.
Does someone know how to solve this issue? Which Audacity version is suitable to run the project?

Many thanks in advance,

Sorry; I didn’t see your post earlier. Zip up your project, upload it somewhere, then send me a link. I’ll take a look at it.

Thanks for your reply. I received help from crisb - he was able to recover the project.
However, it may be useful to extend your helpful guide “Corrupt or Otherwise Broken Audacity Project Recovery” accordingly. Would that be possible?
At least it seems that other users faced the same error when browsing to the forum (just the numbers change).

Thanks. Good suggestion. Actually I’ve only seen one or two of these before, so I don’t have a recovery procedure worked out. But you are welcome to give it a try if you would like. :smiley:

I think the project version may be encoded somewhere in the first 64 bytes of the .aup3 project data file - anyway, that is where audacity gets the bogus version number that it prints. Just change that to a reasonable number; then another recovery pass may be in order. I’ll let you work out the details…

As I said, this case is rare, and it requires just a little TLC. :smiley:

I was able to recover the broken file by means of following steps:

  • Run audacity project tools on the corrupted file.
$ audacity-project-tools -recover_db -recover_project broken.aup3
  • Get a error message similar to this:
    Project requires Audacity xx.xx.xx
    Unsupported project version.

Note that required version may change, e.g., 71.211.6.

  • Open the file in an Hex-Editor, e.g., “Hex Editor Neo”
  • Identify the version required in the first rows of the file by using an ASCII Code Table, e.g., 71 is displayed by 0x47.
  • Change the corresponding fields to 0x00 or something lower or equal than your current Audacity version.
  • Save your changes.
  • Try to open the file in Audacity. If still an error appears, follow the next steps. Else you are fine :slight_smile:
  • Run audacity project tools on the modified file.
$ audacity-project-tools -drop_autosave broken.recovered.aup3
  • Open the resulting file, i.e., broken.recovered.recovered.aup3 in Audacity and acknowledge the warning. The project is recovered.

You may want to append it to the recovery guide in this forum :slight_smile:


Thank you for your post. I cannot seem to identify the version number in my hex-editor, could you provide an example or more detailed explanation of locating this version number?

Perhaps you wish to provide screen shots of what you do have.

Sure, here is the start of my project file in hex, after its been through the previous repair steps

Project claims to require Audacity version 90.167.85

So that translates to 5A A7 55 which corresponds to location 3C. So change those to zeros. Good luck!

1 Like

Thank you! It opened successfully with a mostly restored project

Thanks for the report back. :grinning: