Records voice, but not instrument

Boy, do I feel stupid. Just downloaded 3.3. Now I can record voice but instruments do not record (same track). Using a Yeti condenser mic. I am (obviously) not sophisticated in these matters, but I have tried all the settings on the mic itself and the Audacity audio setup. I cannot understand how it is possible.

Possibly WIndows Audio Enhancements. Have you tried Effect > Amplify ?

Thanks. I don’t show “Amplify” in the Effects menu. But in any event, why would the voice record but not music?

Stranger and stranger… I played a song from my phone into the mic - vocals came through (though distorted) and no instruments at all. This never happened on earlier versions of Audacity

It might be under Volume and Compression.

Thanks. I tried that and got loud, distorted vocal, no instrument. Is there some easy way to go back to an earlier version of Audacity?

Even more strange - just had a Zoom session with my guitar instructor. Same issue - he could hear vocal but no music. Windows 11 issue? I am researching (I can’t be the only one, can I??!!)

See: Redirecting

Thank you, thank you. It is now recording the instruments (I can’t hear it on playback, as I can’t seem to get the volume up through the laptop speakers, but I am working on that).

Thanks again.

Well, it worked until the next Windows update, then had to do it all over again.