Recordings missing

Alright. I recently decided to get back into voice recording, so I opened up Audacity and tested it out with my headphone’s mic. However, when I clicked the square “Stop” button and I try to play the recording, nothing plays at all. I already use Audacity 2.1, and my speakers work normally. I don’t know what’s going on with the program.

Did you make a recording? You should get accumulating blue waves and bouncing red recording meters if you were actually making a recording. If your display is a thin blue horizontal line, you didn’t record anything.

You should select the headphone’s microphone in the Audacity device toolbar. If you have a USB headset, you should get it plugged in and working and then start Audacity.


Yes. I got a recording. I saw blue sound waves. The thing is, it shows the sound waves when I press the red “Record” button, but when I press “Stop”, it changes to a thin blue line and plays no sound.

I mean I know I started recording.

Try this. Before you need to record, open Audacity and save the Project somewhere you know like your desktop. Then press Record and the show shouldn’t vanish when you press stop. Try it on a minute show.


It’s possible you may need Append Record (Shift-R) rather than straight record. I’m fuzzy on how that part works. Please let us know if that worked. This is Audacity 2.1.0.

No, it’s not supposed to do that. We’re still tracking down some odd errors.


You don’t need Append Record. Save the Project and then just Record.
We’re also assuming you called the show something simple without a lot of punctuation marks in it. Dates can cause problems inside filenames.


Alright. It worked when I did that. Thanks.

Also, I know it’s been fixed, but the same thing happened on Audacity 2.0.5, so it’s not 2.1 only.

Your problem happens when Audacity is trying to produce your show on a portion of your drive and is being prevented from doing so. Overly vigorous Virus Protection can do that. Security Permission issues can cause that. And no, that’s not normal.


Do you know how to fix the Virus Protection and Security Permission issues? Sorry. I’m not much of a computer wiz.

If you don’t pre-save a project, then your recordings are stored in Audacity’s temporary directory. Open Edit > Preferences… then choose the “Directories” section to see where your temp directory is.

If you have that directory set to Program Files, or to someone else’s user space you will not be allowed to write there unless you are logged in as administrator.

If that directory is set to some folder with “temp” in its name, which is how it is normally set, then a clean up program may see “temp” and think that it needs to clean the files up. If so your recordings will be deleted while you are making them or soon thereafter. Norton’s Windows Temporary File Cleaner does this.

If this is the problem then you either need to turn the cleaner off or set the Audacity Temporary Directory to some folder that does not end in “temp”. The easiest way to do that is create a folder in C: that you want to use, then type the full path to that folder into the “Location” box in Directories Preferences.

For example, if you create the folder “C:Audacity Recordings” then you can just type “C:Audacity Recordings” into the “Location” box then click OK. You should be able to use a folder you create at the top level of C: even if you are not logged in as administrator.


Alright. Thanks.