Recording won't start [SOLVED]

Hello, I’m from Holland and I’m new here on this forum. My name is Jack and I have the following problem. When I start Audacity to record audio from an Internet site, I push the red button but the needle keeps staying in the lefthand corner. So, it won’t start.
The following pop-up appears and said:
Problem with time delay
The setting for time delay causes the recorded audio is hidden from the time point zero. Audacity has retrieved it so that it starts at zero. Possibly you have to use time shift
(<----> or F5) to drag the track to the right place.

Question: What does it mean and what do I have to do to solve this problem. I don’t understand this.
grtz Jack

What version of Windows and what version of Audacity? Please see the pink panel at the top of the page.

I suggest you use Audacity 2.0.6 from

The message occurs because the recording is stalling and you have Transport > Overdub on. Turn Transport > Overdub off and turn Transport > Software Playthrough off so that both menu items have no checkmark (no tickmark). Also turn Transport > Sound Activated Recording off.

Then if you are on Windows Vista or later, you can record the internet in Audacity using the Windows WASAPI host as described in the Manual ( ).

  1. Open Device Toolbar .
  2. In the first (Host) box of Device Toolbar, choose “Windows WASAPI”.
  3. In the second (Output device) box in Device Toolbar, choose the Speakers or Headphones that you are using for listening.
  4. In the third (Input device) box in Device Toolbar, choose the (loopback) input for the same device you chose in step 3. For example, if you chose “Speakers” in Step 3, choose “Speakers (loopback)” in this step.
  5. In the fourth (Input Channels) box in Device Toolbar, choose mono or stereo.
  6. Start playing the audio you want to record.
  7. Press the big red Record button in Audacity.


Hello Gale, I forgot to tell you that I’m using Audacity 2.0.6 on Windows 7. But you gave me the right solution. Indeed Transport Overdub was checked. The rest of options was unchecked. So, I uncheked Overdub. And that it was! Recording is already possible!
Thank you so much, have a nice day.
grtz Jack

I’m glad it’s solved, though all that unchecking Overdub should have done is to turn off the message, not prevented the stall.

If you experience further issues, have a look at this page to see if you have correct and updated drivers for your sound device.