Recording won't start on pressing Record button

I want to do what i have done many times before - record what I hear playing on the computer (in this case Youtube).

Before, pressing the record button always set the oscilloscope track going, and it was obvious whether or not it was detecting sound. Now, the thing stays stuck at zero position. The triangle turns from green to red, but nothing else happens. I’ve looked at numerous posts but none of the suggestions seem to work.

In frustration I uninstalled Audacity and installed 2.3.3 (21 Jan 2020 Australian time). Looks snazzier but still the same problem. I tried rebooting.
Settings L to R:

  • windows WASAPI
  • Digital Audio (S/PDIF) High definition audio device (loopback)
  • Mono
  • Speaker (6 USB audio device)

Transport options ALL UNCHECKED (including overdub and sound-activated recording)

Windows 10 Pro
64 -bit operating system, x64 based processor
Note that the sound has failed on the Gigabyte motherboard, so I am using a USB plug-in device, which is (from memory) for some reason called a 7-channel thingy, and is not wonderfully reliable but is obviously working when I can hear Youtube through the speakers. This has not prevented similar recording by Audacity before, though I did encounter lots of setting problems that needed professional help to overcome.

I’ve tried everything I could think of or find, so now I’m hoping one of you will have a solution.

At one stage by the way I got an error message similar to that mentioned on another post, that said something about “Error … check settings and …”. ? But recently I have not been able to regenerate that message.


I am using a USB plug-in device

It might pay to learn more about that.

I think you can do that trick with a simple Behringer UCA202. Strap the Line-Ins to the Line-Outs and then use the UCA202 as both playback (from YouTube) and recording (to Audacity).

That will also give you the problem of two different volume controls that have to work with each other to get the show volume to come out right, and/or you might not be able to hear what you’re doing in real time.

Nothing in here?


Hi Koz

(a) I don’t know the brand of the device, but it’s labelled “7.1 Channel Sound”, and consists of a black box with rounded edges with a USB plug poking out one end. It has two buttons (one of which is a mute, that is not muted, plus volume up and down buttons, a red and a green light, and headphone and speaker jacks on the end opposite the USB. Shonkily made, but as long as it works that’s all that matters.

(b) Audacity has always recorded stuff played on the computer before, so long as the settings were correct. Pressing the record button resulted in the oscilloscope trace haring off to the right, and if there was no sound input, showing a flat line trace. Now, none of that happens - it just sits at starting position and goes nowhere and does nothing (whether there is sound playing or not). So that part of the manual is not really relevant.

I am very ignorant about sound processing, settings etc etc, though once I have a WAV trace, I’m in familiar territory. eg if the dynamic range is too small as might happen in the volume mismatch case you mention, Audacity’s selective amplification is very powerful. With no trace at all (not even a flat line) I can do nothing.


I should have added dimensions of the device: 46 mm X 24 mm X 13.5 mm

Has anyone any ideas about what settings I need to change to get this working, as it used to before? :confused: :question:

The progress I’m making is all backwards? Now I cannot hear even a WAV file (stored on my hard drive) playing in Audacity. Zero sound.

I’m fairly ignorant about computer terminology wrt sound processing by the computer. What (eg) is the meaning of “Digital Audio (S/PDIF) High Definition Audio Device”? The Windows 10 troubleshooter decided to Disable this just now. Now I cannot hear the Youtube track. I THINK I have reenabled it, but still cannot hear my audio. At the bottom right of my current screen, the Windows speaker icon says “Digital Audio (S/PDIF) 100%” and has three curves on the icon, not a cross.

What is the “ATAPI connector”? :confused: :question: And for that matter, what is “Windows WASAPI” in Audacity?

What I need, I think, is a step-by-step, properly explained, manual troubleshooting procedure, to get all my Windows and Audacity settings correct. Stumbling about trying things is just making the problem worse.

Hi Ricky,

Last year I was also having a similar issue so I did the same thing as you mentioned here that you uninstalled Audacity and then reinstalled, and after that my problem got solved right away. At that time, my system was windows 8 (but now I have upgraded to windows 10), anyways, so in my opinion, I think it is your system that is causing this problem and not the version of Audacity.


“S/PDIF” is “Sony/Philips Digital Interface”. This is an alternative input/output on some audio devices. When present, it is commonly in the form of an optical connector. Many devices have this option within their audio chip, but on cheaper devices it is often not physically connected to anything (no socket on the device, so can’t be used).
Normally you would want to use “analogue” audio in/out, not S/PDIF.

“ATAPI” is “AT Attachment Packet Interface”. It is an interface for connecting CD drives, Tape drives, Hard drives, and other peripherals to a computer.

“WASAPI” is part of the Windows sound system (Windows Vista and later). It is an alternative to the older “MME” sound system.
(Windows also offers “directsound”, but in Windows 10 this is only an emulation for compatibility with old software that may require it).

WASAPI provides a few features that are not available in MME. The most important new feature as far as Audacity is concerned, is the “loopback” input.
The “WASAPI loopback” input takes an audio input directly from the audio output of the same device. It is a digital equivalent of plugging the sound card output into the sound card input, and allows the device to record what is playing on the computer.

Setting up WASAPI loopback is described in the Audacity manual here: Tutorial - Recording Computer Playback on Windows - Audacity Manual

Thank you Steve - I appreciate the time you took to explain these things. This will help considerably.

I will take a fresh look tomorrow, but still have no strategy for fixing the problem. Back in the days of Z80s, cassette tape drives and the like, troubleshooting often was helped by the availability of stepwise guides, and at some point during those steps it often fixed the problem. These seem to be hard to come by in recent years. That’s really what I need now.

I typed a detailed explanation of how the problem was fixed but your system blitzed it and made me log in again. Haven’t got the heart to do it again. briefly, both Windows (default) and Audacity in 2nd and 4th settings now have “speakers (Realtek USB2.0 audio) (loopback)” - and everything works as it should (so far anyway).

I hope you’ve solved this by now but I just had the same problem, and after 2 hours of searching… … its the bitrate… windows WASAPI only records in 24bit. When you create a new track, its probably defaulting to 32bit… Right click on the track, select “format” and change to 24bit… You’re welcome :slight_smile: