Recording with Digitech RP [CLOSED]

I was recording with a Digitech RP155. The input level was very low. I downloaded the latest driver for the RP155 from the Digitech site. Then the computer was not able to even see the Digitech RP. I uninstalled that driver and could record again but it was still too low. I noticed on the top line of the writing on top of the Digitech the words “USB Record Level” above the third knob. By pressing the edit button until the top line was selected I was able to use the third knob to adjust the level. I am running Windows 7. Hope this helps somebody else.

Put Windows 10 on a small Acer notebook as a test before loading it into my main computer. Made a multi track recording using a Shure SM 58 mic, a guitar track, and a harmonica track. All through the Digitech RP155 and USB port. Worked fine. Had to turn up the USB Record Level on the Digitech again. 20 seems to work well. I am using an impedance matching transformer to connect the Shure SM 58 to the Digitech (it is designed for guitars). I found that Audacity will not see the Digitech if you plug in the USB port after starting Audacity. You must hook up the RP to the USB first and then start Audacity. Then you will find the Digitech as an option in the input and output pull down menus. This worked so well that I plan to put Windows 10 on my main computer.

Thank you for your information and tips.

So that others don’t jump into this topic with unrelated questions, I will mark it closed.

As you were not asking for help, I moved it to the Recording Equipment board.