Recording with a 'Line 6 UX1' device


I’m trying to record (using audacity version 2.0.2) vocals and guitar through a ‘Line 6 UX1’ box…meaning both my external mic, instrument and headphones plug into the box and then - through a USB - to my computer. But after many frustrating hours it just won’t work!

I’ve made sure all the settings / drop downs are correct and been into my computers sound settings to ensure the interface is recognised, but still no joy.

It also won’t playback through the headphones that are also connected through the Line 6 box.

It will let me record / playback through the computer’s built-in mic and speakers, but the quality is dreadful.

I use Windows 7 and obtained Audacity through the .exe installer.

Any help and guidance would be much appreciated.

Thank you!


Please tell us what you have set where, and why “no Joy” - what actually happens? An error message? Flat line recording?


Thanks for your response.

The ‘speakers’ and ‘microphone’ drop downs on the main nav bar / section both show the UX1 device and I’ve highlighted them. I’ve also been into Edit-Preference-Devices to make sure the settings are correct in there too i.e. using the UX1.

When I click ‘Start Monitoring’ nothing happens (this does work if I select the computer’s mic!). When I click on the record button it does try to do something in that the grey record bar appears but the vertical line that should scroll across the screen doesn’t scroll.

I’ve tried different USB ports but still nothing!

I’ve read about similar problems - some have suggested it could be a condenser mic issue(?!?) or an issue with the ASIO, whatever that means?!?

Also, I didn’t load the pod farm or line 7 software that came with the UX1. Could that be the issue???


What appears to be happening is that Audacity can “see” the device, but it is not receiving any audio data from the device, so it is “waiting” for the audio to arrive. This would indicate that the device is not correctly configured in Windows.

Check in the Windows Sound Control Panel that the device is enabled and correctly functioning. In particular, check that the recording level is turned up and check that the audio format is set in Windows to the same as it is set in Audacity (sample rate, and number of channels).

The shipped version of Audacity cannot use ASIO and must use the standard Windows drivers.
Audacity cannot directly use the Pod Farm software as that requires ASIO.

You may need to install “Windows Drivers” (WDM drivers) from the supplied disk, but have a look in the Windows Sound Control Panel first as Windows may have installed these automatically.

OK, great. Thanks for your help Steve.