recording what the computer is playing

When i used windows 7 i could record what the computer played, now on win 10 i cant, is it possible? what are the settings if so,

Which version of Audacity? (look in “Help > About Audacity”)

The “WASAPI loopback” method is recommended for Windows 10. See:


its 2.2.2

Ive tried this, didnt work, if i’m using an audio interface tascam us-122 is this my recording device?>

The current (recommended) version is 2.3.0, which is available via the Audacity website: Audacity ® | Download for Windows

“WASAPI loopback” provides a way to record the “playback output”. It is therefore essential that you select the WASAPI loopback device that matches the playback device that you are using.

Usually the easiest way is to playback via the computer’s built-in sound card, and record with the “WASAPI loopback” device that matches the built-in sound card.

The phrase “didn’t work” tells us very little. If you still have a problem, please describe in detail what the exact problem is.

All i get is a dalek sound, see screen shot on this link

Still not got this fixed, any idea?

Have you tried WASAPI loopback?

Yes it just does the above and an awe full noise

Like howling / squealing?

no like dalek noise, like bareble feedback

In this post:
Your picture shows that you have WASAPI as the host and “Stereo Mix” as the recording device. That’s the wrong combination. The recording device should be
called something like “Speakers (Realtek High Definition) loopback”.

I’ll double check thxs

No still same, like a 1970’s raygun sound only way can explain

See video attached

Ensure that you don’t have “Software Playthrough” enabled (Audacity “Transport” menu).

It was enabled, ive turned it off, now when i press record, the timeline dont move anywhere?>

OK, so now you need to play something for Audacity to record.

I press record it wont move, anything else need check?