Recording vinyl through a mixer


I have two turntables and a Numark M6 mixer and I’m trying to record a vinyl mix using Audacity. I’ve got a USB cable plugged into the mixer (Channel 3 USB) which is then plugged into the USB port in my laptop. I can record but the sound quality isn’t great. It will pick up noise in the room and if I whistle during the recording you can see it going up on the level indicator. I’m assuming the connection should be direct and therefore it shouldn’t pick up any additional noise from the room.

Am I doing something wrong and if so what do I need to do as I’m getting very frustrated?

Any help would be very welcome.


I wondered why it was called “Channel 3 USB.” Manufacturers can sometimes hide odd problems behind names like that. But not this time. The connection will send the mixed show to your computer for recording, or, accept sound for arrival on Mixer Channel 3.

Close Audacity.

It’s a good bet you’re recording your laptop built-in microphone or web cam microphone and not the mixer. That will give you ratty music quality and your live voice.

Go into the Windows sound control panels - recording and see if you can figure out which connection is your mixer. It might say Numark, or it might say USB Audio CODEC. You can tell if you have the right one if it vanishes if you unplug the mixer.

If you do find it, make sure the sound meter bounces in time to your music.

As we go. I need to drop for a while.


Apparently you are recording from your laptops built-in microphone…

Select the USB device as your [u]Recording Device[/u]. (Make sure the USB is plugged-in before starting Audacity.)

Thanks for the quick reply folks. USB Audio Codec is the mixer( I unplugged it and saw that it disappeared in the control panel as you said). When I try to record with the mixer connected to the laptop there’s no movement on the green bars on the recording panel in Windows at all and some on the microphone Array above it. I’m assuming this is the internal microphone picking up any external sound which is why the quality is poor.

If I plug the USB cable directly into the turntable which has a USB port and switch it to line from phono it seems to work better. I can see the green bars moving in USB Audio Codec. The microphone array will pick up external sound if I clap for example which I’m not sure is normal or not.

So it feels like the mixer connection may be the issue but I want to be able to record a mix through two turntables so not sure how best to resolve yet. Any more thoughts as it feels like progress is being made?

Thanks again

he microphone array will pick up external sound if I clap for example which I’m not sure is normal or not.

No, that’s not normal. Unless you have a mic plugged into the mixer. :wink:

Windows can only record from one thing at a time, unless you select “loopback” or “stereo mix”, which records everything coming out of your soundcard. (Windows has a built-in playback mixer but there is no recording mixer.)

A quick search through the forum shows that no one has (yet) reported success recording from the M6 Mixer. There is a possibility that the M6 requires ASIO, but I am not (yet) sold on this.

I pulled out and old M6 manual and found that Channel 3 is for your CD Player Input/Computer USB Input. Channel 1 and 2 being your vinyl inputs. So the trick is to see if we can’t get the USB port to be a mixer output.

Try running “mmsys.cpl” from the windows search bar, then (from the M6 manual):

  1. Click the Recording tab and select USB Audio Codec* as the default device.
  2. Click Properties in the lower right-hand corner.
  3. In the new window, click the Advanced tab and select 2-channel, 16-bit, 44100 Hz (CD Quality) as
    the default format.
  4. Uncheck both boxes under Exclusive Mode.

If that doesn’t work, I would probably give up. But not before throwing the book at it: If there is no USB Audio Codec listed under the Recording Tab, try right-clicking near any other device selected, then selecting show disabled/disconnected devices, disabling the USB Audio Codec in the Playback tab, rebooting, etc.

Don’t start Audacity until after Windows sees your the interface (else Transport > Rescan Audio Devices).

The other approach is to use a different USB interface such as the behringer uca202/222. (And of course your turntable USB). Keep us posted.

No, that’s not normal.

Something’s broken. When you did the Windows test, did you have the Numark master sound meters up to at least zero and maybe higher?

Screen Shot 2021-09-13 at 1.26.27 PM.png
Dance Mixers split the show into different versions. One version goes out to the big amplifiers and sound system. One version goes to the booth on its own volume control and one version goes to the recorder.

The recorder version is usually “clean” without all the equalization and processing if your mixer has that. There’s just nothing like trying to send a recorded performance to the floor and have it go through equalization twice. The recorder version is most likely going down the USB cable, since the instructions say so.

If I plug the USB cable directly into the turntable which has a USB port and switch it to line from phono it seems to work better.

I think you just killed your mixer—or at least the USB Recorder connection.


I pulled out and old M6 manual

That came up, too. How old is the mixer? Has this ever worked? Did you buy it new?


From the M6 quickstart guide:

to these inputs.
7. CH3 USB – > Outputs the Record mix to your computer for recording purposes > or sends incoming audio
from your computer to mixer’s Channel 3.

The USB interface on your mixer works with your computer just like a standard USB sound card. In addition, the USB interface is
class-compliant, so > there are no special drivers or software to install; simply connect a USB cable from the
USB port to your computer and you are ready to go!

So it’s supposed to work.

There is also a switch on the Mixer’s front panel for selecting the USB as input. You might try switching that to “line” in case the USB doesn’t work as input and output at the same time.