Recording suddenly happening on end of rhythm track

Last month I did a whole recording using a rhythm track and the recording would happen wherever I placed my cursor, on the track that I had the focus on. Now all of a sudden, it doesn’t matter where I have the focus on, whenever I click on the record button, the recording happens at the end of the rhythm track. I’ve seen people saying I should click on “Record on new track” on Preferences, but I don’t want to start a new track every time I hit Record, I want it to just keep recording on the same track I had. Why is the cursor moving to the end of the rhythm track? This is so annoying.
My version was 3.0.3 and I updated it to 3.0.4, resetting my preferences but it didn’t help.
Thanks for any insight you can provide.

There are two settings for where to put a new recording. Place it at the end of an existing track, and “Somewhere Else.”

Audacity > Edit > Preferences > Recording > [X] Record on a New Track.

If that’s it, don’t let it go by you that that setting is not supposed to change by itself…

Don’t ignore red flags.


Are you trying to jam everything onto one track instead of spreading it out over multiple tracks? Bad idea, but that’s up to you.

You probably want the Punch commands.


I want to place it at the end of an existing track, one that I added below the rhythm track.
I click on the second track (not the rhythm one), I see a vertical black line on it, the track itself is highlighted in yellow (selected). When I click Record, the black line goes to the end of the rhythm track, and a red cursor shows up at the end of that track.

No, I’m not. I don’t want to record on the rhythm track, I created a new track and am trying to record on that one, but even though it’s selected, and the cursor is on a different point on the timeline, when I press record it goes to the end of the rhythm track duration and starts recording there. With my Scarlett interface it records on the rhythm track itself, now attempting with the regular laptop microphone it records on both tracks, again, at teh end of it.

I read that four times. I think I got it.

I created a new track and am trying to record on that one.

It doesn’t work like that. Audacity will create a new track, not at the end of the rhythm track, but in a blank screen. Don’t make an empty track first.

And you have to change the preference to not try and make the rhythm track longer.


Thanks… I’m really puzzled because that’s definitely how I did it last time, and it worked, I clicked “record” and it recorded at the end of the track I was working on, not the rhythm, and not into a brand new one created automatically.
I’ll try to use the option to create a new one, but having tons of tracks to manage after stopping and starting recording a few times might get aggravating.
What is this preference to “not try and make the rhythm track longer”?

I had to leave in the middle of a thought.

There is one magic possibility. What you had before was broken. That happens occasionally. Somebody builds an empire on what turns out to be a software error.

Is this what you want? These are the preferences.

Screen Shot 2021-09-18 at 21.01.57.png
I selected the middle of the three tracks and pressed the red record button. That thing on the right is my laptop microphone capturing my voice.

Screen Shot 2021-09-18 at 21.02.53.png

Yeah, here I simply can’t make that work, no matter what track I select, it gets added to the rhythm track, not the specific one I was selecting.
In any case I’ll need to record to a new track because the purpose of the rhythm track is to have it playing while I record something, and doing an “R” instead of Shift-R starts at the end of the click which defeats its point.
Thanks again.

Are you recording mono or stereo? (look in the Device Toolbar)
Is your click track on a mono or stereo track?
“Preferences > Recording → Record on a new track” - is that ticked or not ticked?

It’s only one input coming from my interface, so I had created a mono track for it. The click track is also mono. “Record on a new track” was not ticket because I wanted to add the recording to the end of my current track, it’s just that no matter whether there’s nothing on my currently selected track, once the record button is pressed, it “fills” up the track and the sound starts filling the end of the click track.

But what about the “Recording Channels” setting in the Device Toolbar?

So this afternoon I tried again and the behaviour was like I was expecting, for some reason. At one point I decided to remove the track and create it again (because I realized I had to create a Stereo track even though I was recording using only one input, because of this and then the behaviour reverted to the one I didn’t want, adding it to the rhythm track. I came to the forum and saw your comment re: the device toolbar, and once I picked the correct options there, the behaviour was fixed. So, all I’m saying is that it’s something that has to do with that toolbar. Thank you!!!