Recording streaming audio

Since upgrading to Windows 10 I have been unable to make a decent recording from the internet. I am using Audacity v 2.1.2 on a Surface Pro 2. Both W10 and my sound card driver are up to date. On my sound card (Realtek High Definition Audio) I have disabled the internal and external mic and set Stereo Mix to default. On Audacity if I try to use WASAPI I get an error message, I presume because I can’t set up a loop on the input - I only have Sound mapper, mic and stereo mix as options. If I use either MME or Direct Sound as soon as I commence recording - even without an input - I get a background noise, somewhere between a hum and a whistle. The noise increases with the Audacity input volume control. The sample rate is 2 channel, 16 bit, 48kHz. With an input from, say, Youtube, it records, but you can hear the noise in the background.

Does anyone have any ideas?

On Audacity if I try to use WASAPI I get an error message, I presume because I can’t set up a loop on the input

Have you tried selecting “speakers” as your recording input? You want to capture the signal to the speakers. If that doesn’t work your drivers may not be up to date, or maybe you upgraded to Win10 and there are no Win10 drivers for your soundchip.

as soon as I commence recording - even without an input - I get a background noise, somewhere between a hum and a whistle.

Make sure [u]Software Playthrough[/u] is turned OFF.

[u]Here is a tutorial[/u] about recording streaming audio (or other computer audio output) including some alternate hardware & software solutions if you can’t get Audacity to work… It can be tricky because different hardware, drivers, or operating systems may require different solutions.

As I said in my original post, drivers and W10 are up to date. Also, playthrough is turned off. The tutorial doesn’t help. I have now downloaded from the Windows store the Sound Editor App by McCalla and this records perfectly, without changing any of the settings. :frowning:

A lot of users think their drivers are up-to-date because Device Manager says so, but if you look at the driver provider it might say “Microsoft”. That is often a problem because those drivers are not ones made by the sound card manufacturer and then provided by the computer manufacturer.

We’re just saying. If you already got the latest audio drivers for Windows 10 from your computer manufacturer then you “should” be OK.

Presumably then it uses whatever the default Windows recording device is, which you said was Stereo Mix.

It could be you needed to persist with WASAPI host in Audacity. If you use WASAPI and change settings in Windows Sound, you must restart Audacity or you will receive the error you mentioned.

If you can save your recording as a WAV file you can always edit it in Audacity, if you want to.


Thanks, Gale, for that explanation. I have actually gone through via Control Panel and updated the driversd and got the message back “The driver you ar using are the most up to date available”.

The Sound Editor app only worked once, after that it didn’t record at all.

I don’t understand when you suggest that I should “persist with WASAPI host in Audacity” - can you clarify this please? If I set the Audio Host on Audacity to WASAPI and leave the Control Panel- Sound -recording- input unchanged as Stereo Mix, I still get the background sound on top of the recording.

You say “make sure software playthrough is turned off” - I can’t now find “software playthrough” - is this the same as “listen to this device” on the Stereo Mix tab? That is not ticked.

Unfortunately, that is not an absolute guarantee that you have the best drivers. It just means that you have the best drivers that are in the Microsoft database, which might possibly only be generic drivers made by Microsoft (you can check the driver provider in Device Manager). See Updating Sound Device Drivers.

In your case, as the computer is made by Microsoft you might really have the best drivers, but to be sure you could download the latest packages from

That could be a problem, or not. If that application requires stereo mix to record computer playback, but stereo mix was not Windows default recording device at the time, that could cause it not to work.

It means, experiment with sample rates and Exclusive Mode in the playback settings in Windows Sound for the device whose playback you are recording.

Right-click over the speaker icon by the system clock, then choose “Playback Devices”. Right-click over the playback device you want to record from then choose “Properties”. Then click the “Advanced” tab. Try setting Default Format to a 44100 Hz choice, and untick both Exclusive Mode boxes. OK, restart Audacity and set project rate bottom left of Audacity to 44100 Hz.

In Audacity, turn Transport > Software Playthrough off and turn Transport > Overdub off so that there are no tick marks by those items.

If it still errors. go back to Windows Sound and try ticking both Exclusive Mode boxes. Close other applications that might have been playing sound previously. OK and restart Audacity. WASAPI can be a little finnicky.

Where is the sound playing? In the web browser? That should be OK, but one scenario where WASAPI loopback can’t record is if the application playing the sound demands exclusive access to the sound card. This might happen if you were playing sound in a high end digital workstation application and trying to record that in Audacity.