Recording Slightly Too Fast

I’m using Audacity 2.1.2 on my MacBook Air running El Capitan (downloaded the .dmg).

When I record using the built-in audio, everything goes fine, but when I use my Zoom H2 connected through USB, I’m getting strange behavior. If I record myself playing an F major scale, it comes out sounding about a semitone higher and a little bit faster. In addition to being faster, the audio also has spots where it sounds like it’s skipping back just a little bit here and there, especially around the beginning of notes (kind of like a stutter). The track sample rate (and the sample rate on the microphone) are both set to 44100. If I change the track sample rate to 40517 (multiplying 44100 by the ratio 44100/48000) after recording, this fixes the pitch problem, but not the skipping.

I have tried adjusting the “Audio to Buffer” setting, but that hasn’t produced any difference.

Oh, and I’m just playing back through the built-in output.

Any help would be greatly appreciated.

You probably have that upside down. If the playback is too fast, that usually means the performance was recorded too slow. That would make more sense as having the computer not be able to keep up with real-time data is pretty likely, particularly if you have other sound damage like repeating phrases. You didn’t say so, but I bet after the repeating phrase, you’re actually missing a tiny portion of the show.

Anything in here help? Have you been through this already?

MacBook Airs are not super-powered speed demons. Their sole reason for existing is to last a long time when you use one in a restaurant or other out-of-office location. So saving battery life takes unquestioned priority over everything else.


I switched to using the other USB port on my computer for the microphone, and that seems to have resolved my problems for the time being. Not sure why that would make a difference, but I’m glad it seems to have abated.

5 years later, I am experiences the same problem…
MacOS: 10.15.7 Catalina
Audacity: 302 and 242

When I record my own voice with Zoom H1, firmware 2,10, connected as a USB microphone, it plays back too fast with a hi pitch. If I adjust playback speed to 0.9x it sounds about right.
It is very consistent, so I suppose has nothing to do with skipping parts.
I am think of maybe bit sample rate? Though both zoom and audacity display 44.1khz.

Switching USB(c) ports on my 2020 MacBook Air i7 did not help. MacBook on power, not battery.

PS: I did a final google search just before hitting submit and… this video came to the rescue:. Set the bitrate with the Mac USB MIDI app. Problem solved!