Recording/Record Button Problem

I am using Linux Mint 17.3 Cinnamon, with Audacity 2.1.2. I was using 2.0.5 (from the distributor), but just updated using the downloaded PPA. I am running a dual boot system with Windows 10, and the problem I’m about to describe is specific to the Linux installation. The Windows installation of Audacity does not exhibit this problem. Windows 10 has been very problematic for me, so I’m trying to avoid using it as much as possible.

I have no problem recording the first track. Press the record button, and Audacity functions as it should. When I press the record button to add a track, a new track is created but nothing records. Instead, the stop button “greys out” immediately (as if it had been pressed), and nothing is recorded on the new track. I have to keep pressing record and … eventually … a new track is created that begins recording normally. I then have to go back and delete all of the empty tracks. This problem also existed with my 2.0.5 installation, so I updated in the hope that this would solve the problem. It didn’t.

This problem seems to be specific to recording using a Roland Duo-Capture USB audio interface. When the recording device is set to default (the computer’s built-in microphone) Audacity operates normally.

Has anyone encountered this problem and (if so) what is the solution.


If you updated to Windows 10 over previous Windows you can for 30 days roll back to previous Windows (in Settings).

So are you choosing the USB (hw) recording device in Audacity)?

If you have Transport > Software Playthrough enabled in the Audacity menus, you could try turning that off.



Thanks for your response. In answer to your questions …

DUO-CAPTURE: USB Audio (hw:1,0) is one of the selections in the recording device dropdown menu. Software playthrough is off. Finally, by the time I realized the Windows 10 was causing my problem, the 30 period had expired. (I’m enjoying Linux Mint and I have MS Windows 10 to thank, so the problem wasn’t all bad news.) There are times I will need to boot into Windows 10, since certain applications only work with Windows, but that will be the exception rather than the rule.

Are you connecting the Duo to an empty USB port on the computer? You should not connect to a USB hub connected to a USB port.

Also try shutting down the computer then wait a few seconds before rebooting.


The Duo-Capture unit is connected via an empty USB port on the computer, not a hub.

I shut down the computer and also disconnected it from its power source, waited several minutes, then rebooted. The problem remains. I still have to click on the record button and create multiple new tracks before one will actually record.

No-one else has that problem as far as I know. The subsequent recordings are stalling.

Are you actually doing overdubs? If you turn off Transport > Overdub as an experiment, does the problem persist?

Are you recording at an extreme sample rate? Try 44100 Hz bottom left of Audacity.

Does your Duo support Linux? Roland do not claim support for Linux. They offer special drivers for Mac and Windows. This means it is not intended as a class-compliant USB device that would be expected to work “as is” on Linux.

Also the device is not listed on either as Duo or UA-22. If the problem persists I would ask on the Linux Mint forums if anyone has written a Linux driver for it.


Interestingly, when I turn off overdub there are no recording “false starts.” I don’t know what that tells us, but I need overdub so leaving it off isn’t an option.

The Duo Capture switch is set at 44100, and that’s also the setting on Audacity.

Linux support is unclear. I did find it necessary to set the Duo Capture ext switch to **. (The alternative is * which Roland indicates is the normal position for that switch. I have no idea what ext means, what “normal” refers to, or what the switch is designed to do. I did find online postings where other Linux users reported that Audacity would not recognize the Duo Capture unless the switch was set to **.)

While Roland doesn’t claim support for Linux, it does seem to work … albeit inconsistently. The first time I press record it functions exactly as it should. Subsequent presses of that record key fail more often than they work. It may take a half dozen or more attempts to actually record a new track, but when it finally records Audacity performs perfectly (I wish I could say the same for myself). Then I have to go back and delete all the empty tracks that were created but which failed to record. Not a show stopper, but certainly annoying.

I will attempt to find a Linux driver, if there is one out there. In the meantime I guess I’ll keep creating unrecorded tracks and then deleting them. I’d rather do that than reboot into Windows.

Thanks for the time you put in on this problem.

Thanks for the information. That Ext switch doesn’t seem to be mentioned in the User manual (for Duo-Capture-EX, anyway).

You could try increasing “Audio to buffer” in Audacity’s Recording Preferences. On Mac and Windows there is a control panel where you can adjust the Roland buffer size, which interacts with the Audacity buffer size. I don’t know where if anywhere that control is exposed on Linux.


Thanks again for your input. For what it’s worth, here’s some additional information.

The Duo-Capture (DC) and Duo-Capture EX (DC EX)are different devices, models UA-11 and UA-22 respectively. Checking the Roland website (which doesn’t provide support for Linux), they appear to use different drivers. As far as a Linux driver, so far I’ve found nothing, but I’m still looking.

The DC manual refers to the ext switch as a “feature expansion” switch, whatever that means. It seems to be only on the DC, not the DC EX.

Checking the documentation, I noticed that the DC uses a 24-bit sample format, while the default with Audacity is 32-bit float. So I set Audacity to 24-bit to match the DC. It didn’t solve the problem.

I tried adjusting the Audacity Audio to buffer from the default 100 milliseconds. I went as high as 300, but the problem persists. When I rebooted to Windows 10, I followed the directions to see if I could adjust the Roland buffer size, but I was unable to do so. I think that’s because the driver listed is no longer a Roland driver, but appears to be a Microsoft driver required for Windows 10, and adjusting the Roland buffer size is an advanced driver setting.

I don’t know if any of this info is useful. Regardless, thanks again for taking so much time with this problem.