Recording problems with bass and sound quality from Laptop

Version 2.2.2
Windows 10
I’m using a laptop, Lenovo Ideapad y700

I’m using audacity to record audio clips from YouTube so that I can splice rearrange, edit certain parts to make music through FL studio.
I started recording music recently and I decided to hook up my Bluetooth Bose speaker to test the bass levels of my recordings. The sound quality just is not there, and the bass is either extremely low or non existent. When I play the music directly from YouTube through my Bose speaker, it sounds great. If I play the recording through my Bose speaker, there is no bass or sound quality. I have Audacity set to record from Stereo mix (Realtek high definition) and have tried switching between direct sound and WASAPI. I have already read a few threads and the answer that I had come across is that my sound card might have some settings that automatically tweak the sound levels down for my laptops speakers, and that is why I have poor recording quality.

This thread( viewtopic.php?f=46&t=81498&start=20 ) page 4

Apparently the issue can be fixed by using a desktop, but I have not tried this myself. Is this the only answer? Is there any way to work around this? If my speaker can play such great quality music from you tube why can’t I get audacity record the same exact sound/ quality and present it in the exact same way?

Thank you! <3

Nobody at YouTube is jumping up and down to allow you to record their shows and no computer advertises the ability to do that. People recording computer playback are all using work-arounds or computer service tricks rather than official offerings.

Playback and Record are two independent pathways. Recording playback requires you to cross them. Earlier computers brought the sound all the way up through conversion to analog in the soundcard and then turned it around for recording. In those cases, yes, you got all the computer’s playback effects, filters and corrections plus no ability to set volume. If that’s what you have now, then that’s probably what’s happening.

Pure digital “foldbacks” should not have that problem. The digital bitstream, usually undistorted, is made available for recording. However, if your machine picks a bad node for foldback, it could pick up all the computer’s voice processing on the way. Do you like to use Skype or other chat program? Those are famous for taking over a computer’s sound channels and making them safe for conference mode chat. They’re also notorious for not allowing recording of the chat.

This is one place where consulting the manual isn’t going to help. They’d just as soon you fail. Google your computer model for user postings.


I have already read a few threads and the answer that I had come across is that my sound card might have some settings that automatically tweak the sound levels down for my laptops speakers, and that is why I have poor recording quality.

Yes. There should be a setting for “internal speakers”, “headphones”, or “external speakers”, etc.* I don’t remember exactly where that setting is (and I’m on a desktop computer right now) but I remember starting by right-clicking the speaker/volume icon.

Bass is filtered-out when using the built-in speakers because they can’t reproduce bass anyway and filtering it out means you can go louder without distortion.

I’m not sure why there’s a difference between the original sound and the recorded sound, except the bass would be filtered-out twice.

I thought WASAPI loopback would capture the unfiltered audio stream but I haven’t tried it. With Stereo Mix you usually get exactly what’s coming-out of your soundcard/speakers so if you turn-down the playback volume (or add any EQ or other effects) it also affects the recording.

So is there a possibility that getting an external sound card with a pure digital fold back would allow me to record that audio more efficiently?

If your computer has a built-in sound card (most computers do), then you should be able to use that.

So that we can advise further, from Audacity, select “Help > Diagnostics > Audio device info”.
Wait a few moments for the info to appear, then click the “Save” button and save the info somewhere convenient (such as your Desktop).
Then attach the saved file to your reply.
See here for how to attach a file to a forum post:

Hey thank you! This is the device information.
deviceinfo.txt (4.68 KB)

Yes, you can use the following settings in the device toolbar:
host: WASAPI
Recording device: Speakers (Realtek High Definition Audio) (loopback)
Playback device: Speakers (Realtek High Definition Audio)

Check in the Windows Sound Control Panel to see what the “sample rate” is for the Realtek High Definition speaker device. If possible, set it to 44100. It is essential that this sample rate matches the sample rate in Audacity, so if 44100 is not available for the device, then you will need to change Audacity’s settings to match the device.

Additional details here: Tutorial - Recording Computer Playback on Windows - Audacity Manual

So I’m having the same issue, however, the fix recommended isn’t available.

I have an HP Elitebook with Windows 10, and for “Recording” in my Sound Control Panel, my only option is called “Stereo Mix.” This is supposed to be a direct recording of what’s coming to the sound card, however all bass is removed when I record.
My built in Sound Card is a “Conexant ISST Audio” not the RealTek.

Any ideas?

I’ve considered using my iPhone’s headphone adapter as a “Mic” input on my docking station (listed as External Microphone on Recording Tab), but I haven’t tried that yet.

Thank you all!
Sound Control Panel - Recording Tab.PNG
Sound Control Panel - Playback Tab.PNG

thank you it was helpful