Recording Problem

Hi everyone. I apologize if this has been covered but I cannot find the answer in the forum.
I have just downloaded ver. 2.1.2 on my Windows 7 desktop.
I have stereo mix enabled and selected as the recording device and MME selected.
My problem is that nothing records when I hit the record button and no waveforms are showing.
Is there a setting somewhere that I am missing? I have even tried uninstalling and re-installing Audacity.
Thanks in advance for your help.

You can use Windows WASAPI loopback. See this Tutorial .


Thank you so much for your quick response!
I just tried the WASAPI loopback method and I received this error message: “Error while opening sound device. Please check the recording device settings and the project sample rate.”
I also tried with stereo mix disabled and the error message disappeared but nothing is recording.
Any additional help would be deeply appreciated!

With WASAPI it is best to start the stream playing before recording. And you should choose the same device for playback and recording so for example headphones for playback and headphones (loopback) for recording.

Turn Transport > Overdub off.

More help here:

Do you have correct and up to date Windows 7 audio drivers for your build-in sound device, if that is what you are using to play audio? If not, recording might not work correctly. See Updating Sound Device Drivers.


Thanks again Gale! I hate to be a pain…

I just checked and my drivers are up to date. I believe I am using the built in sound device and am using the same device for playback and recording (speakers). I also have overdub off and start the stream before I hit record.
I have even tried to change the project rate to 48000 to no avail. Any other ideas?

Are they the correct drivers from your computer manufacturer’s web site? Device Manager may tell you the drivers are up to date, but that is only according to the drivers database that Device Manager can find.

When you record with Stereo Mix, have you turned up the speaker volume and turned up the Audacity recording level slider?

With WASAPI loopback, you may have to try turning off both Exclusive Mode boxes (in Windows Sound, in the Properties for the Speakers playback device). Then make sure that whatever sample rate you choose in “Default Format” above the Exclusive Mode boxes, choose that same rate in Audacity’s “Project Rate”.

Or, turn on Exclusive Mode then choose a sample rate in Audacity’s “Project Rate” that is listed in “Default Format”. Restart Audacity after making any changes in Windows Sound.

Also are any other applications running that use the sound card, such as a game or some assistive technology? If an application demands exclusive use of the sound card, WASAPI loopback recording won’t work - it will just say error opening sound device.


Thank you so much once again for you help Gale!

I tried everything you suggested to no avail. Incidentally I installed Audacity on my laptop which is running Windows 7 Professional which lists the default sample rate at 16 bit, 48000Hz and it worked right out of the box. Unfortunately, the laptop only has a small lame speaker so it is useless for editing audio.

My desktop with a great sound system is running Windows 7 Home Premium (Default: 24 bit, 48000Hz, Realtek High Definition Audio). I went on the Dell site and it said I have the current drivers. I tried unchecking the Exclusive boxes and experimented with different sample rates. In some configurations I got the error message. In others, when I attempt to record the red vertical bar moves but nothing is recording. I did restart Audacity and even re-booted the computer after any changes. I do not have any other applications running or any assistive technology.

I made sure that the speaker volume and the Audacity recording level slider were turned up.

Do you have any other thoughts before I throw in the towel?

Thanks again,

Which combination of settings with WASAPI host results in no error but a flat line recording?

Have you tried all three hosts (MME, Windows DirectSound and Windows WASAPI) with Stereo Mix? If Stereo Mix always has the same flat line problem as WASAPI loopback there is probably some explanation for that. If you Effect >Amplify… the recording then click OK, is it still silence or a recording?

You could attach the information from Help > Audio Device Info… (top right of Audacity) to see if it gives us any ideas. Click OK in the Audio Device Info to save. Please see here for how to attach files:

Are these built-in speakers you are using, or do you have external speakers connected - if so , what output are they attached to? How many physical outputs does the computer have? Are headphones or anything else connected to other outputs?

If you can’t resolve it you might be able to download the audio you want using an extension for your web browser. It depends where the audio is that you want to record.


Hello Gale,

I have tried all three hosts and these are the results:

MME / Microsoft Sound Mapper / Speakers => Flat line
MME / Stereo Mix / Speakers => Flat line
Windows Direct / Stereo Mix / Primary Sound Driver => Flat line
Windows Direct / Stereo Mix / Speakers => Flat line
WASAPI / Stereo Mix / Speakers => Flat line
WASAPI / Speakers / Speakers => Error Message

I have attached the device info to this for your review.

I have external speakers attached from the back of the computer (3 wires) to a subwoofer, central channel, and 4 surround speakers. Nothing else is connected to the other outputs.

I don’t know if this is relevant but when I use Windows Movie Maker, the only way to hear the audio is by having to have Windows Media Player open. I have tried that with Audacity to no avail. Could Media Player be a culprit in any way?

Thanks again for all of your help!
deviceinfo.txt (4.68 KB)

What are the other output ports on the computer meant for, that you are not using?

I suggest you could go into Windows Sound, Recording tab, right-click in empty space, choose “Show disabled devices”, then right-click again and choose “Show disconnected devices”. Repeat the same actions on the Playback tab, restart Audacity and post Audio Device Info again. I think it is possible you have a separate headphones or other output device that is disabled and that the Speakers device that you currently do have enabled is somehow mapped to that other device which you are not using. It might matter for recording playback.

I would certainly, after showing and enabling all devices in Windows, open the Realtek control panel and look at the output configurations and computer audio port mappings that are available.

The other consideration is that you have a multi-channel playback device. Audacity can only play audio mixed down to stereo, and “Stereo Mix” recording is by definition 2 channels (stereo) regardless of which host you choose in Audacity. I have never been clear whether WASAPI loopback can record multi-channel (more than stereo). We have seen questions suggesting WASAPI loopback cannot record multi-channel, but WASAPI loopback in your Audio Device Info claims eight recording channels are available.

So, how many recording channels are offered in the last box of Device Toolbar when you choose WASAPI (loopback) as Recording Device? If more than two channels are offered, have you tried six channels or eight channels, and is your sound card configured to mix down to stereo for applications that don’t support multi-channel playback? It is possible that Windows MovieMaker does not support multi-channel playback and this is why you have to open Windows Media Player to hear sound in MovieMaker.



I have attached the device info for you.

I am showing under playback (show disabled devices):
NVIDIA HDMI Output (port 0) not plugged in
NVIDIA HDMI Output (port 1) not plugged in

Under Recording:
Realtek High Definition Audio not plugged in
Line In
Realtek High Definition Audio not plugged in

I don’t believe I have a Realtek Control Panel - I can’t find it.

“So, how many recording channels are offered in the last box of Device Toolbar when you choose WASAPI (loopback) as Recording Device?”

I have 2 choices, mono or stereo. Choices 3-8 are left blank.

" is your sound card configured to mix down to stereo for applications that don’t support multi-channel playback?"
I don’t know to be honest, I can’t figure that out. In the sound section in Control Panel, I was able to see it is configured as 7.1 surround. I changed it to stereo and I lost all sound. I re-booted the computer and it automatically reset to 7.1
deviceinfo2.txt (4.83 KB)

Your Audio Device Info is the same as before. You have to enable a device in Windows Sound before Audacity will see it.

Did you find and enable any more playback devices other than the HDMI outputs? Again, those are not in your Audio Device Info.

You almost certainly do have a Realtek Control Panel. Look in Hardware and Sound in the Windows Control Panel.

Do you mean when you select Speakers (loopback) as the Audacity Recording Device that you see an entry for mono and stereo recording in the Recording Channels box, and then six empty entries? If so have you tried selecting the last entry?

Are you willing to record in stereo or must you record in surround sound? Where is the sound that you want to record? Is it playing in a web browser? What type of computer port are the speakers connected to? Is it a single 1/8 inch port and then the cable to the speakers splits into three? Or are there three ports? If you can connect the stereo output to the Line In with a cable then you can record from the Line In, but only if you enable it in Windows Sound so that Audacity can see it.

If you want to record surround sound playback you may need another application to do that.