Recording Problem With Sound Blaster Audigy FX card

I built my PC 4 years ago with Windows 7 Professional 64 bit. I have 16gb ram and an Intel 15-2400 processor. I used the Realtek onboard HD audio until about a week ago when I decided to upgrade(?) to a Sound Blaster card. I bought and installed a Sound Blaster Audigy FX card. I immediately noticed that I had no sound so I first tried disabling my Realtek onboard audio, figuring there was probably a conflict, and that seemed to fix that. So all seems well until I need to record some audio. I have used Audacity for years and love it, never had an issue of any kind until today. I wanted to record an audio clip from a video I was watching. When I press record in Audacity, I get an error message “Error while opening sound device. Please check the input device settings and the project sample rate”. When I open Preferences>Playback>Devices, I see Playback 2 - Sound Blaster Audio. Under Recording>Devices I see No devices found. To further test Audacity, I opened an audio file and tried to play it back. I cannot playback audio files in Audacity through Playback 2 - Sound Blaster Audio. I have to select Microsoft Sound Mapper as output device.

If I disable Sound Blaster in Device Manager and enable Realtek, I can record and playback audio as before.

Help please.

Self Recording depends on the sound card, driver software and operating system all holding hands. Check for updated driver software or Google for problems with your combination. If the computer doesn’t make sound available to Audacity, that’s the end of the story. There is no way for Audacity to “go around.”

Self Recording is not a guaranteed service like running the screen and mouse. If you “officially” complain about it being missing, the response is likely: “Yes, it might be.”

It gets better, bad driver software can kill Windows. “How come I get a BSOD when I run Audacity?” Because Audacity steps on the driver and the driver…boom.


Someone posted an almost identical question to you to our feedback address, but sent from another address. Feedback@ is not for support questions, but I’ll repost my answer in case you are the same person asking for help.

I suggest installing (or reinstalling) the proper drivers for your particular SoundBlaster for your version of Windows, assuming Creative still support your device. Please see:

Then you will need to restart the computer and enable all the SoundBlaster inputs in Windows Sound. Please see: for help enabling inputs and outputs and setting compatible sample rates on Windows Vista and later.