Recording problem with fast track pro and Audacity

Hi all,

I have read through all of the threads I could see about the audacity recording problems but haven’t managed to get my problem fixed yet. I am having problems recording audio using audacity and the M- Audio fast track pro usb soundcard.

I have a fairly complicated system at present for doing digital DJ sets and internet radio. My system is below and I have tried to make my setup clear with the picture below.

Model: Dell Inspiron 510m Laptop
OS: XP sp3
CPU: 1.39GHz
Memory: 2GB (2 X 1GB)

I’m using Audacity 1.3.11 beta

I am creating mixes using mp3’s and mixing software (virtual DJ) controlled by a usb midi controller called a Hercules mk2 plugged into my laptop.

On the other side of my laptop I have my fast Track pro plugged into the usb port and this is controlling the sound. I have left and right phono channels 1&2 and 3&4 routed into the back of Allen and heath mixer.

From that mixer I have audio outputs to my amp and monitor speakers and crucially back into the fast track Pro via the large inserts 1&2.

Despite this being a rather complicated system it works beautifully and the audio is great. However I simply can’t get audacity to record the signal that comes from the mixer via the inserts 1&2 and back into the computer.

This is what I see in Audacity:

As you can see I have set both the recording and playback to the Fast track pro. I have also set this in my laptops sounds and audio control panel.

I have tried pretty much every combination of audio inputs and outputs but to no avail. Can anybody help?



It looks like you have a bit of something recorded, though the level is very low. (the blue line in Audacity does not look completely flat, though it may just be the picture). Try selecting the track (or part of it - mouse click and drag) and apply the “Amplify” effect from the Effects menu (with the default settings). Is there anything there?

I see you have selected "MME: Fast Track pro 1/2) for both IN and Out. That should be OK, but what other options are there?

Yeh I think its noise though.

I amplified it and it’s just a hiss.

My other options are shown here:

How interesting.

I have had a major breakthrough here after a good couple of weekends playing about with this.

The screen shot shows that if I set the recording to fast track pro S/PDIF then I get a decent signal!This is weird becasue I have nothing plugged inot that input on the fast track pro… My inputs are in the Inserts 1 &2.

However it’s only from one channel on my mixer and weirdly all of the things that I usually use to control the volume (mixer levels, master out, fast track pro levels etc) have no effect on the singla volume at all. Very weird.

Actually now that I think about it that must mean that the singal that audcaity is picking up isn’t going through the external mixer at all.


Close Audacity, go into the Windows Control Panel and in the “Sounds and Audio Devices” section, set the default input and output to the Fast Track Pro device.

Play something in Windows Media Player and check that the output is working.
Open Microsoft Sound Recorder and check that the input is working.

If we’re all GO, open Audacity and set the input and output to Microsoft Sound Mapper.

You beat me to the post :smiley:
If you’re currently on line, give me a couple of moments to type -

That is weird.

We’ve seen some pretty strange problems with Fast Track Pro’s - it seems that they make nice ASIO drivers (which are not supported by Audacity) and then just cobble together the Windows drivers - but it’s the first time I’ve seen this.

I think you need to work out exactly what signal paths are going on here while we sort this out.
Disconnect the Hercules for now, connect a known good signal source to inputs 1 and 2 of the Fast Track (for example the CD player) and reboot the computer. Then follow the steps in my previous post to see if you are getting correct record/playback through Windows.

I had used my FTP for several months for playback on my stereo, everything worked fine
Then I decided to start rip my vinyl so bought the right cable to connect my turntable to teh FTP
Monitoring on the FTP was crisp and clear through headphones, so the signal was captured well by the FTP
However, couldn’t get anything to record on my PC with Audacity (tried 3 other softwares as well, none of them could record the FTP input). I tried every possible option.
It had to be the driver
so I deleted the driver
I was on Windows 7, upgraded to Windows 7 SP1
Then re-installed the FTP driver, the one for Windows 7 SP1
Selected Line 1/2 as input in Audacity and everything worked!!!