Recording plays a semitone low

Reference https://forum.audacityteam.org/t/mac-pro-optical-in-problem-stuck-44-1-low-pitch/40738/1 that’s REALLY annoying!

My father’s got exactly the same problem, except it’s the other way round!

Not a Mac, granted, but a new Toshiba laptop running Windows 10.
Hasn’t optical out - just a stereo headphone socket - so he’s run a mini-stereo lead out to a A/D converter box, and then either optical or coaxial to his digital recorder.
According to Audacity, the laptop recording is at 44.1, and the cable ‘locks’ successfully to his Roland something-or-other, also set for 44.1.
The plan was to add some further tracks over the top of the original audio, and produce a new CD (which also has to be at 44.1)
It records fine, and playback of the original is excellent - until he disconnects the digital cable and breaks the connection!
At this point the recorder ‘notes’ the disconnection, and he has to accept the ‘internal’ (?) setting - from then on, the recording plays above a semitone lower/slower!
As far as he can figure out, although the converter claims “Support for sampling rate at 32, 44.1, 48 and 96 KHz.” the important thing to note is that it “Supports output sampling rate at 48KHz.”
In other words, it only actually “transfers” at 48KHz, and not the 44.1 he was after!
He’s yet to find an adapter/converter that will actually do it without costing him an arm and leg!
If anyone knows of such a beast, please let me know!
My mother claims that she’s not heard “such language” from him for years!

As your father is not actually on a Mac (which is a completely different operating system) I moved this to the Windows board.

Exactly what is he trying to record - a MiniDisk?

Exactly what is the make and model number of the converter? Where does Roland come into it? Is that the recorder?

What host are you choosing in Device Toolbar? Try setting host to Windows DirectSound then project rate bottom left of Audacity to 48000 Hz.

If the recording is actually longer in time than it should be, you can fix it by using the Audio Track Dropdown Menu and “Set Rate” to 48000 Hz.


Gale

Well, I’ll try and answer as many of your questions as I can, but I’ll not be able to speak to the ol’ feller for a few days, so some of this will be from listening to his previous ranting!

The audio on the laptop is taken from a single record that he played on many years ago.
(Why it’s on the laptop, I don’t know. Maybe he’s not got the physical 45 any longer?)

From what I gather, he wanted to use the original audio as a basis for some new piano (?) and guitar parts that he was going to try and add on top, and then produce a new CD from the result

For whatever reason, he’s trying to get the original track moved across to his Roland recorder - sorry, all I know about that is that it’s a ‘digital recorder’, and knocking on a bit! (Like him!)

I know nothing about the make/model of the ‘converter’ he’s tried, but I know he’s tried more than one - sorry.

Ditto for his choice in Device Toolbar, but I suspect he’ll have gone through whatever’s there as options! It’s safe to assume that he’ll have checked the project rate and made certain it was 44.1, and definitely not 48 - it’s the 48 that’s causing him (and anybody else in earshot!) grief!

I disagree. If there is a fault with the converter so that it only deals with 48000 Hz and then Windows changes the speed by forcing the sample rate back to 44100 Hz, one way of dealing with that would be to change the host to Windows DirectSound and Audacity project rate to 48000 Hz.

Speed and pitch of a human-audible signal recorded correctly at 48000 Hz, 88200 Hz or whatever is not automatically higher than if recorded at 44100 Hz. The problem is that hardware and software somewhere do not agree about what the rate is.


Gale

Most digital recorders I know will always lock to 48 KHz if you use the spdif coaxial or optical connector. If you send it 44.1 KHz, the recorder will request 48 KHz and will get it from the computer, no matter what the original is.

I don’t know how Windows 10 behaves, but I’d expect it to do the same.

There are a few exceptions, from Sony and Roland, but these are very, very old and require to set switches to behave differently. External switches in the Roland case, internal dip switches in the Sony case. And it usually doesn’t work at all with other equipment.

OK, boys - thanks!
I’ll see if I can ring him tonight to pass on your thoughts/advice and if so will post (some of!) his responses on here.

(I really can’t believe I’m getting involved with this, but anything for a quiet Christmas!)

Managed to have a quick word with him, but he was shortly having to go to work, so it was a bit rushed I’m afraid.

In short - he’s tried 3 different ‘little black box converters’ and they’ve given the same problem. (Logic would seem to hint that all 3 wouldn’t have the same fault?)
He’d also tried altering the Audacity rate to 48 and connecting, but the result was ‘the same’.
The one thing I forgot to ask was the Roland recorder type, but he did blather on about it being able to handle ‘coax’ (?) or optical. Apparently all he does is connect whichever cable, and then do something on the Roland to make the connection ‘lock’. (His words, not mine) He has to choose from 3 different rates, one of 'em being the famous 44.1.
As I mentioned before, it successfully records, but as soon as the cable is removed, the recorder forces him to reset the clock - again, his expression, not mine! - to internal (?) and from then on the new recording runs down-tuned.

For 48000 Hz project rate to help, he must choose Windows DirectSound in Device Toolbar, not MME.

Is the recording actually longer in time than it should be, or not? If it is longer and you have a simple translation to 44100 Hz of audio that should be at 48000 Hz, then simply fix it after the event by using the Audio Track Dropdown Menu and “Set Rate” to 48000 Hz.


Gale

I did tell him about the DirectSound setting, but can’t remember his reply to the suggestion, (if any).
As regards your comments about the recording length of time, I’m sorry, but I haven’t a clue what you mean!
It lasts as long as it lasts!

If he plays a three minute song on the recorder and records it into Audacity then stops recording, it should show up as 3 minutes in Audacity.

The fact that it plays at low pitch suggests that such a three minute recorded song is actually longer than 3 minutes in Audacity, in which case Set Rate or Effect > Change Speed… will fix it.

If the three minute song that plays at too low pitch actually shows up as 3 minutes in Audacity, then either the built-in playback device that the system falls back to is broken, or the recorder/converter is broken, but in the latter case you can use Effect > Change Pitch… to fix it.


Gale

I understand now - very clever, Gale - thank you!
I’ll pass on your suggestion and let you know when I hear the result.

Any further thoughts on this problem, please?
I did pass on your deliberations to my old man (who’s getting extremely terse with my activites!) who pointed out that I should remind my “informants” (!) that he’s trying to get audio from Audacity to the Roland, not the other way around.
He’s totally convinced that it’s the fault of the converters now - he reckons that all (3?) automatically use a sample rate of 48 to transfer - “they might support 44.1 and others, but only actually sample at 48…”

?

We don’t understand enough of what he is trying to do and why. If he wants to play a song in Audacity to some unknown Roland device, why does he need some unknown converter to do that?

What exactly is the audio that he is playing in Audacity - is it an audio file like a WAV, or is some of it audio that he recorded using a converter, as you suggested in your first post? Have you established if the audio currently in Audacity plays at the correct pitch when he plays it to the computer sound card?

If the audio currently in Audacity is really at the correct length and pitch, then perhaps you could export it or the individual tracks to WAV and import the WAV files into the unknown Roland device.

Also why does he not ask these questions here directly himself?


Gale

I thought we’d gone through this already?! He has a song recorded in Audacity on his laptop. His intention was to ‘transfer’ it to his Roland recorder in order to add some tracks over the top, recording them through the Roland. The Roland has some digital inputs (as well as some mono jackplug inputs) but his laptop only has a stereo headphone socket out (i.e.not SPDIF)

I’m guessing that the audio is in MP3 format. I’m also guessing that he made the Audacity recording from a CD that someone will have loaned to him, presumably playing in the laptop CD drive. The only time I mentioned a converter was when he was trying to transfer it to the Roland. He seems happy that the Audacity recording is at the same pitch/length as original.

I’m sure he realises that, but just tried the digital inputs as an experiment. They are there, therefore he tried to use them.

If he had an internet connection, I’m sure he would!
I wish he had!!

What is the “Roland something-or-other”?
Does he still have the CD?
Why does he think that it is playing a semitone low?
If you put the recorded file on a USB stick and copy it to your computer, does it still play a semitone low?
Does the original CD play a semitone low?

Does this Roland not have an analogue input? The laptop won’t have a digital sound card, so why use a converter with an optical output? Audio transferred over optical is usually at 48000 Hz, as cyrano said, so this is probably the cause of the issue.

As Steve suggested, can he bounce the Audacity recording off the Roland to WAV and play it on the computer, to ascertain if it’s the right pitch when played on the computer?

Why does he need to disconnect the converter from the Roland once he has made the recording from Audacity? Even if he needs to do that so he can connect a mic or whatever, this should not (I would have thought) affect playback in Roland. If he was prepared to give the model number of this Roland we might be able to find an online manual for it.


Gale

Finally remembered to ask - VS880, but an EX version (?) apparently.
I suspect he’ll have any manuals that are still available.

So this is not an Audacity problem at all?

if not, it is available here: http://www.rolandus.com/support/by_product/vs-880/owners_manuals/7559
and additional support material here: http://www.rolandus.com/products/vs-880/support/

Just a thought…
When recording from its digital input, it will probably synchronise to the device that it is connected to. Normally this will be 48 kHz. I don’t think that you’ve told us what A/D converter you are using, so I’ve no idea if it can support anything other than 48 kHz.

The sample rate in Audacity is irrelevant because your connection from the computer to the A/D box is analog.

The default sample rate for VS880 recordings is 44100 Hz (44.1 kHz). If you do not specify the sample rate when you create a new song, then it will be 44.1 kHz (from the manual). So, if you are recording a 48 kHz data stream into a 44.1 kHz song, the recording will play back too slow / low.
If you/he has not done so already, try creating a new song with a sample rate of 48 kHz and then try recording.

I presume that you / he realises that recording digitally in this way offers no benefits to sound quality.
MP3 recordings are lower quality than CD, so there is immediately some sound quality loss there, and then the quality is limited by the computer sound card and headphone amplifier. You would probably get better quality by just connecting an audio CD player (“Aux output”) directly to the analog inputs of the VS880.

My thanks, Steve, for your information/confirmation.
As you realised, I personally know less than nothing regarding audio and recording, so I’ve merely been a ‘post office’ during all these conversations - I was just tryng to help the old man out!
So - back to square one, I think! - is there an analog to digital converter that transfers at a rate of 44.1 as opposed to 48?!