Recording no longer starts until sound starts


I upgraded to Audacity 2.1.3 on my Windows 10 laptop via the .exe. installer and I may have inadvertently reset some preferences…?

My devices are set now as I believe they were before:
Audio Host - Windows WASAPI
Recording Device - Speakers (High Definition Audio Device)(loopback)
Recording Channels - 2 (Stereo) Recording Channels
Playback Device - Speakers (High Definition Audio Device)

Prior to upgrading, I would follow these steps to create MP3s from my laptop:

  1. Click the Audacity “Record” button
    The recording starts (a flat waveform until the actual sound starts).
  2. Start the sound playing
    Normal waveform begins.
  3. [When sound ends] Click the Audacity “Stop” button.
  4. Click File > Export Audio [use installed LAME to export audio to MP3 format]
  5. Name and save the MP3 file.

Now when I click “Record”, the button appears depressed but the recording won’t start until I start the sound playing.

Everything then works as it did before.

It will even continue to record (silence) after I stop the sound; it just won’t record the silence at the beginning.

Any advice as to what I’m doing wrong?

Thank you!

I don’t know what the solution is but that might be normal… I’ve seen this problem reported before…

Just doing a quick search I found this on a Microsoft programming-related website:

Another oddity is that WASAPI will only push data down to the render endpoint when there are active streams. When nothing is playing, there is nothing to capture…

…The flag in question is AUDCLNT_BUFFERFLAGS_DATA_DISCONTINUITY. When the song stopped, no more data was available to capture. Eventually the song started up again, and WASAPI dutifully reported that there was a glitch detected. This app stops on glitches.

One solution was to run something called silence.exe (and I didn’t dig-into where to find that).

…So one work-around might be to generate a silent file and play it with Windows Media Player in the background to keep WASAPI “alive”. But, that’s going to take some computer resources and you could end-up with other problems/glitches, plus it would be an annoyance.

You’re right… sounds like this “solution” may cause as many problems as it fixes :wink:

I wonder whether it’s possible to revert to the previous Audacity version…? This issue didn’t manifest until I upgraded.

Thanks in any case for your quick reply.

I had the same problem, until…
Check Edit, Preferences, Recording then uncheck field Sound Activated Recording.

Works for me

I am now having this same problem. It was fine on my other PC, but I switched to a new PC and can’t get it to start recording immediately when I hit the “record” button any more. I have WASAPI set up, and the box to enable sound-activated recording is UNchecked. What is wrong, and how do I fix it? (I’ve attached a screen shot showing the two preferences panels.)
Audacity Panels.jpg

Yeah… That’s normal with WASAPI loopback. If there is no audio stream it won’t record. (A silent stream is OK.)