Recording - No Devices Found


I recently built a new PC with an Asus Z77 Sabretooth motherboard which has onboard HD audio.

On my last pc which had a soundcard Audacity worked fine.

Now with the integrated audio, I can’t record.

Audacity detects the RealteK HD audio for playback but not for recording:

I have tried updating to 2.02 but no luck.

Try enabling the inputs in WIndows: .



The inputs are enabled however the only inputs are microphone and line in and I have nothing to plug into either.

I’m running Windows 7 64 bit.

Never had this problem before. Simply enabling devices was sufficient, in fact my laser software programme picks up its input from the speaker output which is how I thought Audacity always worked.

Self Recording is not a guaranteed service. Earlier Windows just presented all the services and devices and let you straighten them out. Self Recording was one of the services/devices. The more modern Windows simplified the system and some computers have no self-recording at all and need extra software to do it.

Audacity has no dog in any of these races. If the operating system presents audio, Audacity will record and manage it. If it doesn’t, well…


OK I understand that but it can be solved.

My laser programme Pangolin Beyond was also unable to detect any devices. However their technical team brought out an update within a few days that detected Real HD as an audio input.

What recording inputs are available in the Windows Sound Control Panel ?

Just these:

Those are the (only) devices that are available for Audacity to use.
For alternative ways to record sound that is playing on your computer (streaming audio), see the notes here: Windows Sound Control Panel.