Recording is highly distorted and at a low volume.

I am using Windows 7 Audacity 2.1.2, just installed a few hours ago. Installed Audacity using .exe installer.
Sound hardware is Audigy 2-ZS.

I am attempting to record some vinyl LP’s. I believe my physical connections are good b/c even before I start Audigy I am hearing the music through my computer speakers with good volume & quality.

Once in Audigy I have selected MME / “What you hear (Creative SB)” for Audio Device and Recording source. Monitoring seems to be satisfactory, but recording is highly distorted & muted. See screenshot.

I have tried different recording levels and fiddled with other settings…no luck.

As a test I changed the audio device to my webcam mike and was able to make a quality recording of my voice. Any ideas of what could be going on?
audigy_screenshot.jpg
Thanks!
Eric

I have selected MME / “What you hear (Creative SB)” for Audio Device and Recording source.

Probably not. What-U-Hear is a special, folded-back sound pathway so you can record on-line content, YouTube audio, etc. If you’re just recording a turntable, that will give you multiple sound pathways and the feedback paths will create distortion.

The quick version is to select your sound device directly in Audacity and Recording > [X] Playthrough so you can hear what you’re doing.

You should also make sure your Windows Enhancements are all turned off. Windows naturally assumes you want to Skype to your company offices and automatically applies noise reduction and other processing. As a rule, the processing hates music.

http://manual.audacityteam.org/man/sample_workflow_for_lp_digitization.html
http://manual.audacityteam.org/man/tutorial_copying_tapes_lps_or_minidiscs_to_cd.html
http://manual.audacityteam.org/man/tutorial_click_and_pop_removal_techniques.html

All these came from the Audacity on-line manual.

http://manual.audacityteam.org/

Koz

Missed one. Sometimes Windows will assume you want your living room to sound like a cathedral. I personally ran into that one. That’s another setting.

Audacity doesn’t apply any effect, filter or process during recording. These are all Windows problems.

Koz

I have selected MME / “What you hear (Creative SB)” for Audio Device

Select “line Input” (presumably where you’re plugged-in) and that will give you the direct connection Koz is talking about.

And, try WASAPI instead of MME as your audio host. WASAPI is the newest Windows protocol (2007 ?). MME is the oldest (1991 ?), and DirectSound is in-between (1995 ?). Sometimes one or more of these won’t work with your soundcard, but I’d try WASAPI first, then DirectSound, and finally MME if neither of those work.

Hmmm…thanks for the feedback, but what you are saying does not seem to correspond with what I am witnessing.

  1. I reinstalled the audigy 2ZS drivers and I was able to make a satisfactory recording of an LP today, without changing any of the Audacity settings that I reported on in my initial post. However when I went to make a second recording, I got the same horrible results as in my initial post.
  2. There is no selection for “line-input”. The available selections are shown on the attached screen shot. I tried Analog Mix - same result. I did try re-scanning, but nothing new showed up.
  3. I tried both MME (what I used to make the successful recording) and WASAPI - no difference.
  4. I had followed the manual’s procedures before posting here.
  5. I did enable “Recording > [X] Playthrough” in preferences. That didn’t change anything. I still heard the music while recording it, but when I played what was recorded it was distorted.
  6. I’ve tried rebooting and recording with no other programs running…same result. Curiously, the successful recording was done with my usual suite of things running (email client & browser & SQL tools).

Since this problem is so consistent it seems that there is some basic setting that is off. I just don’t know what it is.

I did try ‘piggybacking’ off the successful recording by opening it and initiating a recording of a second track. On the first attempt the recording was good… it did not show the distortion and low recording level. However, on all subsequent attempts the distortion reappeared. Actually, I don’t think distortion is the most accurate term. It looks like the audio signal is suppressed at regular intervals. You can see this in the screenshot.

Thanks for any insight you might have…Eric
audacity_screenshot.jpg

Are you trying to sing along to the vinyl and record your voice as well as the vinyl, or something else you have not explained? Otherwise, if you only want a clean recording of the vinyl, do not choose What U Hear because it is ONLY meant for recording computer playback.

How exactly are you connecting the turntable to the SoundBlaster - do you go through a phono pre-amp or is the turntable part of a stereo music centre? And then to what input exactly of SoundBlaster are you connected? If you are connected to the analogue stereo input, “Analog Mix” should be the correct recording device. If you connected to the optical input, S/PDIF-In is the correct recording device.

Have a look in Audacity at Edit > Preferences > Recording… section. Make sure “Audio to buffer” is set to at least 100. You can try increasing it to 200. If that is not the problem then you may have to go into Windows Sound, Recording tab. In the SoundBlaster Properties for the input you are connected to (see above), try setting Default Format to 44100 Hz.

I disagree with Doug. I would try MME first.


Gale