Recording interrupts although sound activated recording is switched off [SOLVED]

Independent of switching on or off of “sound activated recording” the recording makes a break during silence passages. I get not managed to switch off this feature. I want to go on continuously with the recording even if there is no input signal for some seconds. I want to keep the silence as it is in my recording. What can I do? Is this setting influenced by other settings?
Sorry, if this was already discussed. I could not find an answer here, nor in the buglists.
Using Audacity 2.3.0 on Windows 10 Home 1803 64-Bit on Intel i3-2310M CPU

What are you trying to record?
If you’re trying to record audio playing on the computer, try using “Stereo Mix” rather than “WASAPI loopback” (

Hello steve,
Yes, computer’s audioplaying. Let me first read your link cafully, because I get errors if I select else than WASAPI. I will come back.

Hello steve,

if I select another Audio host (input device), I get an error window as soon as I click to start monitoring on the meter. Error opening recording device. Going to the windows’s sound settings, and indeed, there is no “Stereo Mix” or similar in the recording tab nor in the playback tab. Only microphones and speakers, which I ever connected. Then I checked all my drivers, but they are up to date. Now, I’m a little bugged out, nice weather today and not willed to spend too much time in the depth of Windows. I will do this another time.

I understood, where to look for, therefore thank you!

However, can you tell me, what the choice of the input device has to do with this automatic interruption of the recording? I’d like to get an idea for the background of this.

Regards, Fritzle007

WASAPI loopback is “special”.

You could think of it like a pipe from the audio output to the audio input. Audacity records the sound that comes out of the pipe, but if nothing goes into the pipe (if nothing is playing), then nothing comes out of the pipe, so there is nothing for Audacity to record - not even silence, there’s nothing at all.

So that we can see what options are available to Audacity, please do this:

  1. Close and restart Audacity.
  2. “Help menu > Diagnostics > Audio Device Info”
  3. Wait for the info to appear, then click the “Save” button, and save the info somewhere convenient.
  4. Attach the saved “deviceinfo.txt” file to your reply (see:

Hi steve,

Thanks a lot for your answers on a sunday! I guess I understand the special behaviour of WASAPI when no input is available as it is digital information, even 0000000 is missing, then.

I attach the device info. Some devices have german names, most of them coming from several headsets, I used. I guess, it is a configuration problem of windows 10.
Best regards
deviceinfo.txt (4.5 KB)

Yes, that’s it, but we can probably trick the system. More about this in my next post (I don’t usually use Windows, so I’ll need to look for where the settings are located).

Wow, that really is a very basic / minimal sound system, just microphone in and speakers out only. We are going to have to use WASAPI loopback, and try to trick it into recording the silences.

Out of interest, is this a branded computer or one that was built from parts? Laptop or full size?

Hi steve,

Sorry for my delayed answers, I’m a liitle handicapped by headache and by my job :wink:

Let me try this under Linux, good idea! I’ll come back tomorrow.

Best regards and thank you so far for your explanations


Try this:

  1. “Tracks menu > Add New > (mono or stereo) Track” depending on whether you are recording in mono or stereo.
  2. “Tracks menu > Add New > (mono or stereo) Track”, to create a second track.
  3. Start recording.

By default, Audacity will play the first (empty) track while recording the second track. Because the first track is empty, it should produce a constant stream of 000000… which will keep the recording going, even when the stream that you are recording stops.

Hi steve,

Great! That’s a simple and effective trick. It works. Thank you a lot! You solved my problem!

Finally I want to answer your questions. We never know, whether it is helpful for somebody.
It’s a branded laptop, not built up by myself from parts. I upgraded to Windows 10. In the meantime, I have an idea, what created the problem: It might have been software, which I installed, which might have modified the availabe recording and playback channels. It was simfy and now juke (both something like spotify), which have interest to prevent me from recording, and a language learning software. I have a full pay-account to such a music streaming service, and sometimes I want to store some music on USB to be able to listen to this music in my car, where I have no access to this streaming service. It’s a little mis-use, I know, but I pay for it. And the breaks are important for me. That’s it-

Thanks again for your help!