Recording includes karaoke track too

Dear all,
thanks in advance.
I am very new to audacity.
Recently I am facing a problem with recording vocal in audacity with karaoke track. whenever I am trying to record a new vocal by playing the karaoke track, the recording also induces the music track along with Vocal.

It would be nice of you if you could help me in this regards.

please see the attached image for my settings

Thanks again

You didn’t mention headphones. You need to use headphones when recording with a microphone.

Thanks Steve,
for your quick response.
since my laptop has a single 3.5 audio port and I am just a new learner, I am using a head phone with in built microphoneं&qid=1622550825&sprefix=boat+head%2Caps%2C888&sr=8-3 this one.

let me add one more thing until last week it was working fine.

I must have done something wrong with the setting.

Thanks again.

“Headsets” (combined headphones / microphone) frequently cause weird problems.
What is probably happening is that the output from Audacity into your headset is feeding back into the microphone input into Audacity.

If “overdubbing” has worked for you previously with the same equipment, it could be as simple as the headset jack not being plugged in all the way.

If “overdubbing” has worked for you previously with the same equipment

Historically, that symptom has been caused by someone recording a YouTube song between Working and Not Working. To record on-line content, you have to set up your computer to record its own playback. People leave that setting by accident and when they try to overdub, the recording has both the live performance and the backing track.

One solution is to make sure you’re recording directly from your interface or microphone and not a driver or software redirection program. Your illustration seems to have you recording from your microphone (or array). What’s the possibility that’s a different device from when you had it working earlier? Or that’s an illustration of when it was working?

Also there’s no shortage of people having troubles with Skype or Zoom resetting the sound settings in the computer without telling anyone. You can return to “normal” by clean shutting down your computer. Shift+Shutdown > Wait > Start. Not Restart and not regular Shutdown. Do Not let anything else start when the machine comes back up.

That help?

And yes, as above, Headsets (matching sets of earphones and microphone) can cause problems with cross leakage, especially “Earsets” where simply getting the ear plug in wrong can cause problems.


Something to try if it is still not working: After plugging in your headphones, do Transport > Rescan Audio Devices, then select your microphone in the Device Toolbar.

Question: when I look at your waveform, above, I don’t see your voice - it it there? Note that when you use earbuds you are going to get a little bleed through the air. Take the earbuds out of your ear. Can you hear them? - then so is your microphone. You may have better results with sealed headphones. Also, do the scratch test. Which mike is picking up the sratch? - your basshead, or your laptop mike.

Thanks every one for your help.
Sorry for the delay in reply as I was out of station for couple of days.

Unfortunately the problem is alive till date.

further I have crosschecked without headphone too, even without headphone same thing is happening. My track one is Karaoke track and the second one is while recording is on, suppose to have only vocal, but the recording track is continually recording the karaoke track too, even when i am not using any headphone.
I belie I must have done something wrong with the setup (Audacity or Windows Sound).


What settings do you have in the Device Toolbar now?

I am also facing the same the problem… whenever I am trying to record a new vocal by playing the karaoke track, the recording also induces the music track along with Vocal…
how to solve this ?..