Recording in wrong track

I am having a problem where Audacity is recording to a completely different track that the one I have selected. This problem never occurred in previous versions of Audacity and has only occurred since upgrading to v 3.1.x.

I highlight the track and location in that track where I want to record. I select record, but the actual recording occurs in the first and second tracks at the top of the track list. I have attached a screen print to show what’s happening. I am trying to record in the track titled “Lead Out”]. When selecting the recording button, with that track highlighted, the recording occurred in to two tracks a the top of the list titled “Paddling the” and “Lead In”

I am guessing there’s a setting in the new version that is causing this to happen but I have no idea what that would be or where to look.

For reference, I am using Audacity 3.1.2 and Windows 11

[attachment=0]Screenshot 2021-12-18 142820.png[/attachment
Screenshot 2021-12-18 142820.png

Me too! Win10/3.1.3
Above is me recording. I have used a macro to set this up:-


I load Audacity and immediately run the macro, which creates two mono tracks and (a refinement to see if I can force Audacity to pay attention to only the first track.
I tap the letter “R” and speak, and my voice is recorded on both tracks looking like a stereo wave form.

I use “X” to stop recording, click on the second track (the yellow border moves to the second track) and “R” again and continue speaking, Again, both mono tracks receive sound.

I see the same problem (above) when I run the commands manually from the keyboard/menu.

To the question “Why do this?” i would answer “Because I need to record a pair of tracks for each page of a chapter, or for each chapter of a book”
Thanks, Chris

It’s not a setting. It’s as ChrisGreaves indicated - if you want to record into the selected track, you need to be recording the same number of channels as the selected track. In your example, Audacity is set to record “2 (Stereo) Recording Channels”, but you have selected a mono track.

I am sorry, Steve, but this “Chris Greaves” is not as smart as you make him out to be. Yesterday he was experimenting with resetting the CFG file (the old thread is locked back in 2015), and so when he woke up this morning he was back in Stereo mode.
He is now, as we say in the trade “back on track”; pleased to discover that with a bit more thought, he can solve some problems of his own making, and delighted to find that he is in harmony with an expert!
Cheers and Thanks