Recording in Audacity while playback active

I’ve created two tracks in Audacity and loaded an instrumental accompaniment into the first track. I’d like to play that track in my headphones and then sing into the microphone and record my singing in a second track. I can start the the accompaniment and hear it in the headphones but the ‘record’ button is dimmed in the track I’d like to record to.

Is it possible to playback one track and record to another at the same time? I don’t want the sound of the first track to be in the recorded track.

Sure. That’s called “Overdubbing” and there are instructions how to set up for it.

Note there are two different kinds of overdubbing, plain and perfect. Plain overdubbing is what you posted. You hear the backing or rhythm track in your headphones and when you sing, your voice goes onto a fresh, new track. Save your work and go for coffee. Lots of computers and most soundcards can handle this.

Perfect overdubbing, on the other hand, allows you to hear a perfect theatrical mix of your voice with the backing track in real time. Once you get used to doing it this way, you never want to go back. However, this takes special soundcards. The one in your computer isn’t up to it.

The instructions call three devices that can handle perfect overdubbing. A microphone, a mic preamp, and a stereo interface. I can add one more. The Behringer UM2 can do the tricks needed. Many newer USB sound mixers can do it, too.

There is one weird adjustment call “latency.” When you sing into a sound file, your voice will not always line up with the backing file. You can fix that manually later with plain Audacity Time Shift Tool (two sideways arrows), but that gets old in a hurry, so there is a way to adjust Audacity so the new track automatically lines up with no further effort.

Let us know how it goes.


I don’t want the sound of the first track to be in the recorded track.

There’s a trick to that. For overdubbing, you need to be recording from a physical thing. Something you can reach over and touch.

In this case, my black UM2 on the left is a physical thing.

If you like recording from the internet , then there’s a good chance you’re recording from a software package or driver, not a hardware thing. SoundFlower or iShowU are example of this. You can’t reach over and touch them. They’re pure software. They may route your backing track into your voice by accident.


Have you ever recorded your voice before? It can be a surprise. People still rent quiet, soundproofed studios for a reason.

There’s a joke that I can tell you how big your room is by analyzing the echoes in your voice. You don’t have to actually be in a bathroom to sound like you’re recording in a bathroom.


Hi pinacate. As a recent newcomer to Audacity I strongly advise you to address the latency issue first. It isn’t a lot of fun and it will most likely take you a couple of tries before you succeed, but get it out of the way. Once you’ve done that you’re all set to overdub.

Go to Audacity > Preferences > Recording and make the following settings:
Play other tracks while recording (overdub)
[ ] Software playthrough of input
Record on a new track
Detect dropouts

You can’t start playback then hit record on the fly. Just click the Record button and recording will start on a new track while playing back the existing tracks.

– Bill

I’m able to record with a backing track when I use a microphone. When I route sound into the recorder via Blackhole I get a feedback loop. Your comment about “pure software” may explain the problem. Thanks!!

Got it. I was hoping it was that simple. Thanks!!