recording headphone audio with a dell inspiron

I raised this question a few years ago, and thought I had a solution, but I need to reframe it.

I am using Windows 8.1. When I disable my built in speakers and make my logitech headphones the default device Audacity does not pick up the sound being played on the headphones. If I switch to the built in speakers, it works fine. I’ve tried several settings, including the one below.

The computer is a Dell inspiron, maybe five years old. Someone told me that Dell does something unique with the audio hardware which produces this problem. Can anyone provide help? Has anyone heard of this problem with a Dell? Can anyone suggest a brand of computer on which the headphone arrangement is known to work?

I ask because it’s time for a new computer and I won’t get a dell if the situation persists.

Most people don’t actually want speaker or headphone sound because in general, it means the sound has gone all the way out to analog and come back, picking up distortions along the way, and you’re a slave to the volume settings. Usually, you can have comfortable listening, good recording, but not both. This is how the earlier home computers worked.

This is the posting for “self-recording,” or recording streaming sound (Youtube audio).

Have you contacted Dell? I can’t believe this has never come up. Everybody with a pulse wants to record internet sound.

my logitech headphones the default device

Anything magic about the Logitech headphones? Are they wireless? Are they plugged into the computer soundcard? If they’re not standard headphones, then yes, you are at the mercy of device drivers and special sound software.

Why do you make this distinction? What is there about your system or setup makes this desirable? Your posting rings the bell of “You’re not telling us everything.”


Thank you for your reply, Koz.

And thanks for pointing me to the tutorial–I don;t know much about audio, but will work with the concepts in it.

The reference to the default device was to my settings in Windows control panel.

The whole issue arose because I could not find a way to get sufficient recording volume without hearing a lot of sound coming from my built in speakers. I thought that if I could playback through the headphones, I could set them aside and then work in silence while the recording was made. I hear what you say about the quality that would produce. Perhaps the intention was misguided. I’ll try the tutorial Any other thoughts are welcome.

There are techniques and special services that allow you to capture the playback sound before it goes to the soundcard and your speakers or headphones.

I cheated a bit. Most of the time I’m not listening directly to the soundcard. I have a hifi amplifier and separate speakers. I leave the computer sound all the way up and plug the sound system into the headphone connection.

Most times that’s OK since most computer volume controls reduce sound from no control down to zero. They don’t amplify. This lets me capture internet sounds and still hear pleasant volume in the room by setting the hifi control. In the case of late-night operations I can not bother the neighbors and still hear what I’m doing no matter what the computer is doing.

I’m not a Windows elf, so those instruction pages are it until a Windows person arrives.


Try plugging in your headphones (and ensure that they are working) before you launch Audacity.
Then launch Audacity and get the “Audio device info” "(Help menu > Diagnostics).
Save the info and attach the saved file to your reply.